Harmony
  1. Harmony
  2. HARMONY-2353

[classlib][luni] org.apache.harmony.tests.internal.net.www.protocol.http.HttpURLConnectionTest.testGetOutputStream() intermittently fails

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None
    • Environment:
      SuSE 9, ia32, multi-processor
    • Patch Info:
      Patch Available

      Description

      I can reproduce the following failure:

      Wed Nov 29 03:08:21 MSK 2006
      .E...
      Time: 7.159
      There was 1 error:
      1) testGetOutputStream(org.apache.harmony.tests.internal.net.www.protocol.http.HttpURLConnectionTest)java.net.ConnectException: localhost/127.0.0.1:49599 - Connection refused
      at org.apache.harmony.luni.net.PlainSocketImpl.connect(PlainSocketImpl.java:224)
      at org.apache.harmony.luni.net.PlainSocketImpl.connect(PlainSocketImpl.java:496)
      at java.net.Socket.connect(Socket.java:978)
      at org.apache.harmony.luni.internal.net.www.protocol.http.HttpURLConnection.getHTTPConnection(HttpURLConnection.java:627)
      at org.apache.harmony.luni.internal.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:608)
      at org.apache.harmony.luni.internal.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:929)
      at org.apache.harmony.tests.internal.net.www.protocol.http.HttpURLConnectionTest.testGetOutputStream(HttpURLConnectionTest.java:174)
      at java.lang.reflect.VMReflection.invokeMethod(Native Method)

      FAILURES!!!
      Tests run: 4, Failures: 0, Errors: 1

        Issue Links

          Activity

          Alexei Fedotov created issue -
          Alexei Fedotov made changes -
          Field Original Value New Value
          Link This issue is part of HARMONY-1879 [ HARMONY-1879 ]
          Denis Kishenko added a comment -

          Actually I can't reproduce this issue (200 times in a row) but problem could be the same as in H-1879. I think this patch will fix problem.

          Denis Kishenko made changes -
          Alexei Fedotov added a comment -

          I reproduced the issue runing the test 200 times. After patching I cannot reproduce the problem after 1000 launches. Funny enough, the last testcase, which doesn't contain synchronization, works perfectly.

          Alexei Fedotov added a comment -

          Setting "Patch Available" flag.

          Alexei Fedotov made changes -
          Patch Info [Patch Available]
          Alexei Zakharov added a comment -

          The patch was committed at the revision r484745. Alexei, please verify.

          Alexei Zakharov made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Alexei Zakharov [ zakha ]
          Resolution Fixed [ 1 ]
          Alexei Fedotov added a comment -

          Verified.

          Alexei Zakharov added a comment -

          closed

          Alexei Zakharov made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          9d 20h 6m 1 Alexei Zakharov 08/Dec/06 20:29
          Resolved Resolved Closed Closed
          33d 19h 46m 1 Alexei Zakharov 11/Jan/07 16:15

            People

            • Assignee:
              Alexei Zakharov
              Reporter:
              Alexei Fedotov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development