Harmony
  1. Harmony
  2. HARMONY-2285

[drlvm] several NIO tests crash on DRLVM

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      winXP

      Description

      The following tests from the org.apache.harmony.nio.tests.java.nio.channels package cause DRLVM (debug) crash:

      DatagramChannelTest
      FileChannelTest
      PipeTest
      SelectableChannelTest
      SelectionKeyTest
      SelectorTest
      SocketChannelTest
      SinkChannelTest
      SourceChannelTest
      spi/AbstractSelectableChannelTest
      spi/AbstractSelectorTest

      The tests pass on J9.
      The exact command line to reproduce:
      <harmony-repo-home>\enhanced\drlvm\trunk\build\win_ia32_msvc_debug\deploy\jre\bin\java -verbose:gc -classpath <harmony-repo-home>\enhanced\classlib\trunk\modules\nio\bin\test;<harmony-repo-home>\enhanced\classlib\trunk\deploy\build\test\support.jar;<JUNIT_HOME>\junit.jar junit.textui.TestRunner org.apache.harmony.nio.tests.java.nio.channels.DatagramChannelTest

      1. h2285.diff
        0.8 kB
        Ivan Volosyuk

        Issue Links

          Activity

          Ivan Volosyuk added a comment -

          Reproduced. Investigating...

          Ivan Volosyuk added a comment -

          Fix attached.
          Problem that VM handles more exceptions that it should. Bug was introduced in HARMONY-2006.

          Gregory Shimansky added a comment -

          Fixed has been applied at 478650. Test in description doesn't crash any more

          tatyana doubtsova added a comment -

          I ran nio module iterativly in perTest mode for 50 times on svn = r479111, (Nov 25 2006), Linux/ia32/gcc 3.3.3, debug build.
          1 time out of 50 2 there were two issues in the tests from the above list:

          1). org.apache.harmony.nio.tests.java.nio.channels.DatagramChannelTest@testReceiveSend_NonBlock_Normal_C2S

          Error
          The address is not available

          java.net.BindException: The address is not available at org.apache.harmony.luni.platform.OSNetworkSystem.socketBindImpl2(OSNetworkSystem.java) at org.apache.harmony.luni.platform.OSNetworkSystem.bind2(OSNetworkSystem.java) at org.apache.harmony.luni.net.PlainDatagramSocketImpl.bind(PlainDatagramSocketImpl.java:118) at java.net.DatagramSocket.createSocket(DatagramSocket.java:181) at java.net.DatagramSocket.<init>(DatagramSocket.java:74) at org.apache.harmony.nio.tests.java.nio.channels.DatagramChannelTest.setUp(DatagramChannelTest.java:80)

          2). org.apache.harmony.nio.tests.java.nio.channels.SelectionKeyTest@test_readyOps
          Error
          The address is not available

          java.net.BindException: The address is not available at org.apache.harmony.luni.platform.OSNetworkSystem.socketBindImpl(OSNetworkSystem.java) at org.apache.harmony.luni.platform.OSNetworkSystem.bind(OSNetworkSystem.java) at org.apache.harmony.luni.net.PlainSocketImpl.bind(PlainSocketImpl.java:159) at java.net.ServerSocket.<init>(ServerSocket.java:114) at java.net.ServerSocket.<init>(ServerSocket.java:72) at org.apache.harmony.nio.tests.java.nio.channels.SelectionKeyTest.test_readyOps(SelectionKeyTest.java:299) at java.lang.reflect.VMReflection.invokeMethod(Native Method)

          Vasily Zakharov added a comment -

          The remaining issues look like a duplicate of HARMONY-2338. Should be verified when that one is fixed.

          Alexei Zakharov added a comment -

          I think the problem reported by Tatyana is a separate issue that has no relations to the initial problem. We probably need a separate JIRA for it. The initial problem is completely solved by the Ivan's patch so IMHO we may close this JIRA.

          Vasily Zakharov added a comment -

          Alexei, I've created a separate issue for Tatyana's report, HARMONY-2860.

          Could you please verify Gregory's fix for the original issue and close it?

          Alexei Zakharov added a comment -

          Nice. The original fix was verified. I suppose Gregory should close this (not me).

          Gregory Shimansky added a comment -

          I can confirm that the bug was fixed by Ivan's patch.

          VERIFIED.


            People

            • Assignee:
              Gregory Shimansky
              Reporter:
              Alexei Zakharov
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development