Harmony
  1. Harmony
  2. HARMONY-2231

[drlvm][regression] org.apache.harmony.tests.java.util.regex.PatternTest fails

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None
    • Environment:
      SuSE 9

      Description

      It looks like we've got a regression, see
      http://harmonytest.org/testapp.do?method=showresult&id=2293852

      org.apache.harmony.tests.java.util.regex.PatternTest@testMatches:
      java.util.regex.PatternSyntaxException: Illegal inline construct near index: 3
      x(?c)y^
      at java.util.regex.Lexer.readFlags(Lexer.java:1097)
      at java.util.regex.Lexer.movePointer(Lexer.java:749)
      at java.util.regex.Lexer.<init>(Lexer.java:228)
      at java.util.regex.Pattern.compileImpl(Pattern.java:279)
      at java.util.regex.Pattern.compile(Pattern.java:264)
      at java.util.regex.Pattern.compile(Pattern.java)
      at java.util.regex.Pattern.matches(Pattern.java)
      at org.apache.harmony.tests.java.util.regex.PatternTest.testMatches(PatternTest.java:431)
      at java.lang.reflect.VMReflection.invokeMethod(Native Method)

      The recent related change was http://svn.apache.org/viewvc?view=rev&rev=475869
      See http://wiki.apache.org/harmony/Unit_Tests_Pass_on_DRLVM

        Activity

        Alexei Fedotov added a comment -

        org.apache.harmony.tests.java.util.regex.PatternTest@testCompileStringint fails in a same way:

        Output: java.util.regex.PatternSyntaxException: Illegal inline construct near index: 3
        x(?c)y^
        at java.util.regex.Lexer.readFlags(Lexer.java:1097)
        at java.util.regex.Lexer.movePointer(Lexer.java:749)
        at java.util.regex.Lexer.<init>(Lexer.java:228)
        at java.util.regex.Pattern.compileImpl(Pattern.java:279)
        at java.util.regex.Pattern.compile(Pattern.java:264)
        at java.util.regex.Pattern.compile(Pattern.java)
        at org.apache.harmony.tests.java.util.regex.PatternTest.testCompileStringint(PatternTest.java:359)
        at java.lang.reflect.VMReflection.invokeMethod(Native Method)

        Alexei Fedotov added a comment -

        The bug is no longer reproducible. Please close the issue.

        Tim Ellison added a comment -

        Fixed as cannot reproduce, by Alexei's request.


          People

          • Assignee:
            Tim Ellison
            Reporter:
            Alexei Fedotov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development