Harmony
  1. Harmony
  2. HARMONY-2137

[drlvm][classloader][dacapo] DaCapo jython fails

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Linux

      Description

      DaCapo jython fails with what appears to be a python error. Given that this benchmark runs successfully on at least 6 other Java vms, this would appear to be a problem in drlvm or the harmony classlib. Easily reproduced with the current release of DaCapo at http://www.dacapobench.org/

      $DRLVM_HOME/jre/bin/java -jar dacapo-20061109.jar -s small -n 2 jython
      sys-package-mgr: processing new jar, '/home/robing/tmp/dacapo-nightly-20061109/dacapo-20061109.jar'
      sys-package-mgr: processing new jar,
      ...
      sys-package-mgr: processing new jar, '/home/robing/tmp/dacapo-nightly-20061109/harmony/harmony/working_vm/build/lnx_ia32_gcc_release/deploy/jre/lib/ext/signed.bcprov.jar'
      error importing site
      Traceback (innermost last):
      File "/home/robing/tmp/dacapo-nightly-20061109/./scratch/jython/Lib/site.py", line 66, in ?
      AttributeError: java package 'sys' has no attribute 'modules'

      1. H2137.patch
        4 kB
        Pavel Pervov

        Activity

        Gregory Shimansky added a comment -

        VERIFIED

        Naveen Neelakantam added a comment -

        Confirmed that the bug is fixed at r565477

        Gregory Shimansky added a comment -

        Patch is applied at 564569. Please check that the bug is fixed for you.

        Pavel Pervov added a comment -

        Here is the patch to fix minor inconsistency in DRLVM.

        Vladimir Strigun added a comment -

        The reason of failure is a usage of 2_2alpha1 release of jython in Dacapo. The issue already fixed in jython and I belive new version of jython will appeared in the next major version of Dacapo. The temporary solution (just for testing purposes on DRLVM) is to update jython classes in Dacapo bench. I've checked that the issue is not reproducible on jython 2.2rc2
        More information could be found on dacapo-reseachers archives.

        Naveen Neelakantam added a comment -

        I've had good luck emailing dacapobench-researchers@lists.sourceforge.net when I've run into issues with DaCapo in the past.

        Pavel Pervov added a comment -

        Here we have two problems:
        1) -XX:v.component.classpath.* adds two path separators to boot class path
        2) (1) breaks site.py from jython suite. It reports
        --------------------
        error importing site
        Traceback (innermost last):
        File "/nfs/site/proj/drl/mrt1/users/ppervov/test/dacapo/./scratch/jython/Lib/site.py", line 66, in ?
        AttributeError: java package 'sys' has no attribute 'modules'
        --------------------

        To reproduce (2) run:
        java -Xbootclasspath/a:"foo.jar::bar.jar" -jar dacapo-2006-10.jar -s small -n 2 jython

        It is not important, what java dacapo is being run on. I was able to reproduce this on Sun's 1.5.0-b64 too. It is also true for MR2 release of dacapo.

        (1) should be certainly fixed in DRLVM, but is minor glitch.
        (2) Is there a way to file a bug against dacapo?

        Gregory Shimansky added a comment -

        I've assigned this bug to drlvm based on the above evaluation.

        Yuri Dolgov added a comment -

        I've tried to look make a deeper analysis of the bug and it seems that the problem is in VM part.
        The bug is reproduceble in interpreter mode with option -XX:vm.component.classpath.hythr=hythr.jar

        The followin environment was used:
        SLES 9 Linux, on Harmony r547173
        Command line: java -Xint -XX:vm.component.classpath.hythr=hythr.jar -jar dacapo-2006-10.jar -s small -n 2 jython

        Pavel Ozhdikhin added a comment -

        The checks above were done on the following build:

        Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
        java version "1.5.0"
        pre-alpha : not complete or compatible
        svn = r536135, (May 8 2007), Linux/ia32/gcc 3.3.3, debug build

        Pavel Ozhdikhin added a comment -

        Can not reproduce on Windows/IA32. Reproducible on Linux/IA32 in '-Xem:server' mode. "jet" and "opt" modes work fine.

        Egor Pasko added a comment -

        I observe the same in default mode.
        However, on pure OPT (-Xem:opt) it fails differently (and earlier), I filed HARMONY-2868 for that.

        Naveen Neelakantam added a comment -

        I am also running into this issue.


          People

          • Assignee:
            Gregory Shimansky
            Reporter:
            Robin Garner
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development