Harmony
  1. Harmony
  2. HARMONY-1916

[drlvm][unit] Classlib test java/awt/AccessibleAWTTextAreaTest shows the Debug Error dialog on Windows

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: DRLVM
    • Labels:
      None

      Description

      The following Debug Error dialog pops up on Windows when running classlib awt tests on Windows:

      Debug Error

      DAMAGE: after Normal block (#138431) at 0x04231E20.

      To run tests use the following command line:

      ant -Dtest.jre.home=%DRLVM_HOME% -Dbuild.module=awt -Dtest.case=java.awt.AccessibleAWTTextAreaTest test

      [drlvm][unit] Blocks http://wiki.apache.org/harmony/Unit_Tests_Pass_on_DRLVM

      1. TestTextArea.java
        0.2 kB
        Elena Semukhina

        Activity

        Tim Ellison added a comment -

        Duplicate of HARMONY-1483 as per dev list conclusion on thread
        " [drlvm]"Debug Error!" dialog window occurs when running junit.awtui.TestRunner"

        Elena Semukhina added a comment -

        A standalone test to reproduce attached.


          People

          • Assignee:
            Unassigned
            Reporter:
            Elena Semukhina
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development