Harmony
  1. Harmony
  2. HARMONY-1739

[drlvm] Invocation of JFrame.setVisible(true) into harmony unit tests leads to VM crash on Linux

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: DRLVM
    • Labels:
      None
    • Environment:
      Linux

      Description

      Problem:

      Invocation of JFrame.setVisible(true) method in harmony unit tests leads to VM crash on Linux, but it happens unstable and occurs when test is in JUnit format.

      If VM if run with JET then test fails sometimes with error

      .Uncaught exception in AWT-NativeEventThread:
      java.lang.NullPointerException
      at org.apache.harmony.awt.wtk.linux.LinuxEvent.processConfigureEvent(LinuxEvent.java:358)
      at org.apache.harmony.awt.wtk.linux.LinuxEvent.setEvent(LinuxEvent.java:141)
      at org.apache.harmony.awt.wtk.linux.LinuxEvent.<init>(LinuxEvent.java:78)
      at org.ap
      ache.harmony.awt.wtk.linux.LinuxEventQueue.enqueue(LinuxEventQueue.java:94)
      at org.apache.harmony.awt.wtk.linux.LinuxEventQueue.dispatchEvent(LinuxEventQueue.java:87)
      at org.apache.harmony.awt.wtk.NativeEventThread.runModalLoop(NativeEventThread.java:57)
      at org.apache.harmony.awt.wtk.NativeEventThread.run(NativeEventThread.java:51)
      at java.lang.Thread.runImpl(Unknown Source)

      Code for reproducing (Try to run this test several times):

      import javax.swing.*;

      public class Test extends junit.framework.TestCase {
      private JFrame frame;

      protected void tearDown() throws Exception

      { super.tearDown(); frame.dispose(); }

      public void testTest()

      { frame = new JFrame(); frame.setVisible(true); }

      }

      Running script:

      #!/bin/bash

      1. set path to Harmony
        HARMONY=" ... "

      for i in 1 2 3 4 5; do
      $HARMONY/bin/java -showversion -cp "junit.jar:." junit.textui.TestRunner Test
      done

      Output on RI:
      ----------------
      java version "1.5.0_06"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
      Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode)
      .
      Time: 0.263

      OK (1 tests)

      Output on Harmony:
      ------------------------

      $run.sh

      Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
      java version "1.5.0"
      pre-alpha : not complete or compatible
      svn = r452710, (Oct 4 2006), Linux/ia32/gcc 3.3.4, release build
      http://incubator.apache.org/harmony <http://incubator.apache.org/harmony>
      ..
      SIGSEGV in VM code.
      Stack trace:
      Time: 0.741

      OK (1 tests)

      Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
      java version "1.5.0"
      pre-alpha : not complete or compatible
      svn = r452710, (Oct 4 2006), Linux/ia32/gcc 3.3.4, release build
      http://incubator.apache.org/harmony <http://incubator.apache.org/harmony>
      ..
      Time: 0.746

      OK (1 tests)

      Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
      java version "1.5.0"
      pre-alpha : not complete or compatible
      svn = r452710, (Oct 4 2006), Linux/ia32/gcc 3.3.4, release build
      http://incubator.apache.org/harmony <http://incubator.apache.org/harmony>
      ..
      free(): invalid pointer 0x887fb60!
      Time: 0.746

      OK (1 tests)

      ...

        Activity

        Alexei Fedotov added a comment -

        [drlvm][unit] Blocks http://wiki.apache.org/harmony/Unit_Tests_Pass_on_DRLVM

        The issue is a major showstopper for AWT and Swing integration.

        Ilya Okomin added a comment -

        At first I couldn't run this test case because of issue that had the same nature with HARMONY-1823 one.
        Next exception was thrown: "java.lang.RuntimeException: Shutdown thread was interrupted while stopping" and test hung.

        Then I tried to run test on the drlvm with applied HARMONY-1816 and HARMONY-1823 patches.
        It worked without VM crashes.

        System: RHEL 3AW

        java version "1.5.0"
        pre-alpha : not complete or compatible
        svn = r463607, (Oct 13 2006), Linux/ia32/gcc 3.3.6, debug build
        http://incubator.apache.org/harmony

        Maxim Makarov added a comment -

        I am not able to reproduce this bug and take VM crashe. But the failure is reproducible with RuntimeException because bug H-1823

        Maxim Makarov added a comment -

        plz close the bug as not reproducible

        Gregory Shimansky added a comment -

        Closed by request.


          People

          • Assignee:
            Gregory Shimansky
            Reporter:
            Maxim Makarov
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development