Harmony
  1. Harmony
  2. HARMONY-1679

Timer.schedule(TimerTask, delay, period) doesn't cause repetitive invocation of task

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None
    • Environment:
      Windows XP ia32

      Description

      This bug was found during investigation of unit test tests.api.java.util.TimerTaskTest

      Build: svn = r452457, (Oct 3 2006), Windows/ia32/msvc 1310, debug build

      Code to reproduce:

      import java.util.Timer;
      import java.util.TimerTask;

      public class Test {
      public static void main(String args[])

      { new Timer().schedule(new TimerTestTask(), 50, 50); }

      }

      class TimerTestTask extends TimerTask {
      public void run()

      { System.err.println("running..."); }

      }

      Output in RI:
      running...
      running...
      running...
      running...
      ... (infinite)...

      Output in Harmony:
      running...
      (and no more output)

        Issue Links

          Activity

          Anton Luht added a comment -

          It's DRLVM bug - the problem is not reproduced on IBM VM

          Anton Luht added a comment -

          see HARMONY-1722 for the minimal test case

          Alexei Fedotov added a comment -
          Elena Semukhina added a comment -

          Could not reproduce on drlvm r. 465143.

          Alexei Fedotov added a comment -

          I have modified test a bit so it becomes possible to run it in a loop. All worked fine - please close the bug as not reproducible.

          Anton Luht added a comment -

          verified on

          svn = r471521, (Nov 5 2006), Windows/ia32/msvc 1310, debug build

          Alexey Petrenko added a comment -

          Reporter verified that this issue is not reproducible any more.


            People

            • Assignee:
              Alexey Petrenko
              Reporter:
              Anton Luht
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development