Harmony
  1. Harmony
  2. HARMONY-161

Improper override method in java/util/zip/GZIPOutputStream.close()

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None
    • Estimated Complexity:
      Moderate

      Description

      java/util/zip/DeflaterOutputStream.close() is overriden by java/util/zip/GZIPOutputStream in Harmony while it isn't in spec.

        Activity

        Tim Ellison added a comment -

        Verified by Paulex

        Paulex Yang added a comment -

        The codes is fine, thank you, Tim.

        Tim Ellison added a comment -

        Paulex,

        Applied patch to ARCHIVE module java.util.zip.GZIPOutputStream at repo revision 386064.

        Please check that it was applied as you expected.

        Paulex Yang added a comment -

        Pls. try this patch, thx. I didn't write new test because this patch removes one overridden method, and I have tried the test in the contribution of Harmony JIRA 57, the result is same with before, so I considered this patch passed regression test.


          People

          • Assignee:
            Tim Ellison
            Reporter:
            Paulex Yang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development