The codes look fine, thank you, George.
And thank you special for your detailed observation and comments, my comments below:
>> 1) The native source patch code for this issue also made updates to the
Yes, the two patches are relevant, sorry for that, seems the two JIRA should be merged as one, because they need to modify same native files. I shall try to be more considerate later.
>>2) The patch to java/util/zip/Inflater.java does not update the signature of
Yes, you are right again. It's my fault on this.
>>3) I have a gut feeling that there could be more test code for these changes.
I didn't include them because in fact the new methods are only extended version of some original methods, like getTotalIn(), etc, so the behavior should be same except when the total bytes are larger than Integer.MAX_VALUE, but IMHO this case is hard to test(we may need a huge zip file...). But you are right that it still needs more test.
4) The Javadoc comments for the new methods (e.g. getBytesRead) don't contain much explanation. What do you think ?
Because of the same reason above, the Java doc is short, but I guess I should more explicitly declare the relationship between these new methods and the old ones(currently it is just implied by @see)
I'm willing to create another patch to improve the points above. Your comments?