Harmony
  1. Harmony
  2. HARMONY-1449

[classlib][luni] new methods java.lang.Math.signum(double), java.lang.Math.signum(float),java.lang.StrictMath.signum(double), java.lang.StrictMath.signum(float)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None
    • Estimated Complexity:
      Novice

      Description

      new methods java.lang.Math.signum(double),
      java.lang.Math.signum(float),java.lang.StrictMath.signum(double),
      java.lang.StrictMath.signum(float) in Java 5 but not implemented in
      Harmony(project luni).

      Besides, I'll refactor the test cases in MathTest and StrictMathTest.

      I will attach a patch soon.

        Activity

        spark shen created issue -
        spark shen added a comment -

        Would you please try this patch?

        Best regards

        spark shen made changes -
        Field Original Value New Value
        Attachment Harmony-1449.diff [ 12340708 ]
        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r442916, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        spark shen added a comment -

        The patch looks fine. Thanks, paulex.

        Best regards

        Paulex Yang added a comment -

        Verified by Spark.

        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development