Harmony
  1. Harmony
  2. HARMONY-1436

[classlib][luni]implement new methods digit(int,int),isIdentifierIgnorable(int),isMirrored(int),isSpaceChar(int),isTitleCase(int),isWhiteSpace(int) in java.lang.Character

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      some method such as digit(int,int),isIdentifierIgnorable(int),isMirrored(int),isSpaceChar(int),isTitleCase(int),isWhiteSpace(int) in j.l.Character is missing.

        Activity

        Paulex Yang added a comment -

        Verified by Tony.

        Tony Wu added a comment -

        verified at r443301, thank you.

        Paulex Yang added a comment -

        Tony, patch applied at revision r442914, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Tony Wu added a comment -

        notes that there is a bug of ICU which I has posted on harmony-dev.
        In this patch I just leave a FIXME and will fix it when ICU team fix their bug.

        There is a simple workaround for this bug, I think we can add code below if necessary,

        public static boolean isWhitespace(int codePoint) {
        //FIXME depends on ICU when the codePoint is '\u2007'
        if(codePoint == '\u2007')

        { return false; }

        return UCharacter.isWhitespace(codePoint);
        }

        Tony Wu added a comment -

        patch attached, would you please try it? thanks a lot.


          People

          • Assignee:
            Paulex Yang
            Reporter:
            Tony Wu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development