Harmony
  1. Harmony
  2. HARMONY-1415

[classlib][luni] new method java.lang.Math.expm1, java.lang.Math.hypot,java.lang.Math.log1p, java.lang.StrictMath.expm1, java.lang.StrictMath.hypot,java.lang.StrictMath.log10, java.lang.StrictMath.log1p

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new method java.lang.Math.expm1(double d),
      java.lang.Math.hypot(double x, double y), java.lang.Math.log1p(double d),
      java.lang.StrictMath.expm1(double d), java.lang.StrictMath.hypot(double x,
      double y), java.lang.StrictMath.log10(double d),
      java.lang.StrictMath.log1p(double d) in Java 5 but not implemented in
      Harmony(project luni).

        Activity

        spark shen added a comment -

        Would you please try this patch?

        Best regards

        Paulex Yang added a comment -

        Spark, patch applied at revision r442112, thanks a lot for this enhancement, please verify the problem is fully resolved as you expected.

        spark shen added a comment -

        Hi Paulex, the patch looks fine. Thank you.

        Paulex Yang added a comment -

        Verified by Spark.


          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development