Uploaded image for project: 'Harmony'
  1. Harmony
  2. HARMONY-1387

[classlib][luni]new method java.util.EnumSet.clone, serialization feature, and subclass HugeEnumSet

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new method java.util.EnumSet.clone but not implemented in
      Harmony(project luni). Serialization feature not implemented in Harmony(project
      luni). Subclass used to deal with enum type with more than 64 elements not
      implemented in Harmony(project luni).

      I will attach a patch soon to provide the implementation.

      Best regards

        Activity

        spark shen spark shen added a comment -

        Would you please try this patch?

        paulex Paulex Yang added a comment -

        Spark, patch applied at revision r440652, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        spark shen spark shen added a comment -

        The patch looks fine, thank you paulex.

        paulex Paulex Yang added a comment -

        Verified by Spark.


          People

          • Assignee:
            paulex Paulex Yang
            Reporter:
            spark shen spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development