Harmony
  1. Harmony
  2. HARMONY-1356

[classlib][luni] new method clone(), equals(Object) writeObject(ObjectOutputStream) and readObject(ObjectInputStream) in java.util.EnumMap

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new method clone(), equals(Map) writeObject(ObjectOutputStream) and
      readObject(ObjectInputStream) in java.util.EnumMap but not implemented in
      Harmony(project luni).

      1. Harmony-1356.diff
        8 kB
        spark shen
      2. patch.sh
        0.1 kB
        spark shen
      3. Harmony-1356.zip
        3 kB
        spark shen

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1d 3h 5m 1 Paulex Yang 01/Sep/06 10:48
        Resolved Resolved Closed Closed
        18d 21h 57m 1 Paulex Yang 20/Sep/06 08:45
        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Paulex Yang added a comment -

        Verified by Spark.

        spark shen added a comment -

        The patch looks fine, thank you paulex.

        Paulex Yang made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r439252, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        spark shen made changes -
        Attachment Harmony-1356.zip [ 12339938 ]
        spark shen added a comment -

        This zip file contains all three files.

        spark shen made changes -
        Attachment patch.sh [ 12339937 ]
        spark shen added a comment -

        This is the sh file.

        spark shen made changes -
        Field Original Value New Value
        Attachment Harmony-1356.diff [ 12339936 ]
        spark shen added a comment -

        There are three files. The patch, the .sh file used to copy golden file, and the golden file.This is the patch file.

        Would you please try this patch?
        Best regards

        spark shen created issue -

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development