Harmony
  1. Harmony
  2. HARMONY-1346

[classlib][net] no URISyntaxException for URI(null, ":2:3:4:5:6:7:8", "/", null)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      The method java.net.URI(null, ":2:3:4:5:6:7:8", "/", null) throws URISyntaxException on RI and create URI on Harmony.

      =============== test.java ===================
      import java.net.URI;

      public class test {
      public static void main(String arg[]) throws Exception

      { System.out.println("res = " + new URI(null, ":2:3:4:5:6:7:8", "/", null)); }

      }
      =========================================

      Output:
      C:\tmp\tmp17>C:\jrockit-jdk1.5.0-windows-ia32\bin\java.exe -cp . -showversion test
      java version "1.5.0"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-b64)
      BEA WebLogic JRockit(R) (build dra-38972-20041208-2001-win-ia32, R25.0.0-75, GC: System optimized over throughput (initial strategy singleparpar))

      java.net.URISyntaxException: Malformed IPv6 address at index 3: //[:2:3:4:5:6:7:8]/
      at java.net.URI$Parser.fail(URI.java:2809)
      at java.net.URI$Parser.parseIPv6Reference(URI.java:3430)
      at java.net.URI$Parser.parseServer(URI.java:3180)
      at java.net.URI$Parser.parseAuthority(URI.java:3116)
      at java.net.URI$Parser.parseHierarchical(URI.java:3058)
      at java.net.URI$Parser.parse(URI.java:3024)
      at java.net.URI.<init>(URI.java:663)
      at java.net.URI.<init>(URI.java:764)
      at test.main(test.java:5)

      C:\tmp\tmp17>C:\harmony\classlib1.5\deploy\jdk\jre\bin\java.exe -cp . -showversion test
      java version 1.5 (subset)

      (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
      res = //[:2:3:4:5:6:7:8]/

      C:\tmp\tmp17>C:\harmony\drlvm1.5\build\win_ia32_msvc_debug\deploy\jre\bin\java -Dvm.assert_dialog=false -cp . -showversion test
      java version "1.5.0"
      pre-alpha : not complete or compatible
      svn = r438321, (Aug 30 2006), Windows/ia32/msvc 1310, debug build
      http://incubator.apache.org/harmony
      res = //[:2:3:4:5:6:7:8]/

      1. URITest.patch
        0.6 kB
        Vladimir Ivanov
      2. Harmony-1346.diff
        2 kB
        spark shen

        Activity

        Vladimir Ivanov added a comment -

        unit test

        spark shen added a comment -

        Would you please try this new patch? The old one is outdated.

        Best regards

        Paulex Yang added a comment -

        Spark, updated patch applied at revision r450729, thanks a lot for this enhancement.

        Vladimir, please verify the problem is fully resolved as you expected, thank you.

        Vladimir Ivanov added a comment -

        verified, thanks

        Paulex Yang added a comment -

        Verified by Vladimir.


          People

          • Assignee:
            Paulex Yang
            Reporter:
            Vladimir Ivanov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development