Harmony
  1. Harmony
  2. HARMONY-1344

[classlib][luni] new methods java.util.EnumSet.of, copyOf, range

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new methods java.util.EnumSet.of, copyOf, range but not implemented in
      Harmony(project luni)

      1. harmony-1344.diff
        1 kB
        spark shen
      2. harmony-1344.diff
        17 kB
        spark shen

        Activity

        spark shen created issue -
        spark shen added a comment -

        Would you please try this patch?

        Best regards

        spark shen made changes -
        Field Original Value New Value
        Attachment harmony-1344.diff [ 12339849 ]
        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        spark shen added a comment -

        Sorry, the previous patch is not correct. Would you please try this one?

        Best regards

        spark shen made changes -
        Attachment harmony-1344.diff [ 12339928 ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r438809, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        spark shen added a comment -

        The patch looks fine, thank you.

        Paulex Yang added a comment -

        Verified by Spark.

        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        20h 39m 1 Paulex Yang 31/Aug/06 06:46
        Resolved Resolved Closed Closed
        19d 1h 3m 1 Paulex Yang 19/Sep/06 07:49

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development