Harmony
  1. Harmony
  2. HARMONY-1288

[classlib][luni] new methods java.util.EnumSet.removeAll(Collection<?>), retainAll(Collection<?>), allOf(), iterator()

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new methods java.util.EnumSet.removeAll(Collection<?>),
      retainAll(Collection<?>), allOf(), iterator() but not implemented in
      Harmony(project luni)

      I will attach a patch soon.

      Best regards

        Activity

        Paulex Yang added a comment -

        Verified by Spark.

        spark shen added a comment -

        The patch looks fine. Thank you, paulex.

        Paulex Yang added a comment -

        Spark, patch applied at revision r438017 with minor changes, I removed all @supresswarning tag for generic/casting, because I think we need these warnings until at last we find a satisfied solution or decide to accept them, so far IIUC it is still debatable how to write them in the mailing list. Thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        spark shen added a comment -

        Would you please try this patch?

        Best regards


          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development