Harmony
  1. Harmony
  2. HARMONY-1267

[classlib][luni] new methods ComplementOf(EnumSet), java.util.EnumSet.addAll(Collection), remove(Object), equals(Object)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new method ComplementOf(EnumSet) but not implemented in Harmony(project luni)
      overrides methods.
      java.util.AbstractCollection.addAll(Collection), remove(Object), equals(Object)
      in java.util.EnumSet to use more efficient bits manipulation in Harmony(project luni)

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        23h 40m 1 Paulex Yang 24/Aug/06 10:56
        Resolved Resolved Closed Closed
        10d 16h 21m 1 Paulex Yang 04/Sep/06 03:18
        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Paulex Yang added a comment -

        Verified by Spark

        spark shen added a comment -

        The patch looks fine. Thank you

        Paulex Yang made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r434365, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        spark shen made changes -
        Field Original Value New Value
        Attachment Harmony-1267.diff [ 12339400 ]
        spark shen added a comment -

        Would you please try this patch?

        Best regards

        spark shen created issue -

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development