Harmony
  1. Harmony
  2. HARMONY-1264

[classlib][luni] new methods containsKey(Object) and containsValue(Object) in java.util.EnumMap

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new methods containsKey(Object) containsValue(Object) and equals(Map) in
      java.util.EnumMap but not implemented in Harmony(project luni).

      I will attach a patch soon to provide the implementation

      Best regards

        Activity

        spark shen created issue -
        spark shen added a comment -

        Would you please try this patch?

        Best regards

        spark shen made changes -
        Field Original Value New Value
        Attachment harmony-1264.diff [ 12339389 ]
        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r434364, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        spark shen added a comment -

        The patch looks fine. Thank you

        Paulex Yang added a comment -

        Verified by Spark

        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1d 2h 5m 1 Paulex Yang 24/Aug/06 09:54
        Resolved Resolved Closed Closed
        10d 16h 23m 1 Paulex Yang 04/Sep/06 02:18

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development