Harmony
  1. Harmony
  2. HARMONY-1250

[classlib][luni] new methods in java.util.EnumMap - size, clear, remove(object)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new methods public void clear()?public V remove(Object key) and public
      int size() in java.util.EnumMap but not implemented in Harmony(project luni).

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        21h 48m 1 Paulex Yang 23/Aug/06 05:48
        Resolved Resolved Closed Closed
        7d 7h 15m 1 Paulex Yang 30/Aug/06 13:04
        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Paulex Yang added a comment -

        Verified by Spark.

        spark shen added a comment -

        The patch seems fine. Thank you.

        Best regards

        Paulex Yang made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r433896, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        spark shen made changes -
        Field Original Value New Value
        Attachment Harmony-1250.diff [ 12339288 ]
        spark shen added a comment -

        Would you please try this patch?

        Best regards

        spark shen created issue -

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development