Harmony
  1. Harmony
  2. HARMONY-1246

[classlib][luni] new methods in java.util.EnumMap

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new methods public EnumMap(EnumMap<K,? extends V> m) and public
      EnumMap(Map<K,? extends V> m) in java.util.EnumMap but not implemented in
      Harmony(project
      luni).

        Activity

        spark shen created issue -
        spark shen added a comment -

        Would you please try this patch?

        Best regards

        spark shen made changes -
        Field Original Value New Value
        Attachment harmony-1246.diff [ 12339277 ]
        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r433513, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        spark shen added a comment -

        The patch looks fine.

        Best regards

        Paulex Yang added a comment -

        Verified by Spark.

        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        3h 10m 1 Paulex Yang 22/Aug/06 05:48
        Resolved Resolved Closed Closed
        7d 4h 37m 1 Paulex Yang 29/Aug/06 10:25

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development