Harmony
  1. Harmony
  2. HARMONY-1239

[classlib][luni] new method java.util.EnumSet.contains(Object) - overrides java.util.AbstractCollection.contains(Object)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      overrides method java.util.AbstractCollection.contains(Object) in
      java.util.EnumSet to use more efficient bits manipulation in Harmony(project
      luni)

        Activity

        spark shen added a comment -

        Would you please try this patch?

        Best regards

        Paulex Yang added a comment -

        Spark, patch applied at revision r433503, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        spark shen added a comment -

        The patch looks fine.

        Best regards

        Paulex Yang added a comment -

        Verified by Spark.


          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development