Harmony
  1. Harmony
  2. HARMONY-1220

[classlib][luni] new method java.util.EnumMap.get, java.util.EnumMap.putAll in java.util.EnumMap

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new methods
      public V get(Object key) and
      public void putAll(Map<? extendsK,? extends V> m)
      in java.util.EnumMap but not implemented in Harmony(project luni).

        Activity

        Paulex Yang added a comment -

        Verified by Spark.

        spark shen added a comment -

        The patch looks fine

        Best regards

        Paulex Yang added a comment -

        Spark, patch applied at revision r433136, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        spark shen added a comment -

        This patch provides the implementation for java.util.EnumMap.get(Object) and java.util.EnumMap.putAll(Map), would you please try it?

        Best regards


          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development