Harmony
  1. Harmony
  2. HARMONY-1219

[classlib][luni] new method(s) java.util.EnumSet.add(E) - inherited from java.util.AbstractCollection, java.util.EnumSet.clear, java.util.EnumSet.size

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new method(s) java.util.EnumSet.add(E) - inherited from
      java.util.AbstractCollection, java.util.EnumSet.clear, java.util.EnumSet.size
      but not implemented in Harmony(project luni)

      I will attach the implementation soon.

      Best regards
      Spark Shen

        Activity

        spark shen added a comment -

        The patch provides the implementation for method java.util.EnumSet.add(E), java.util.EnumSet.clear, java.util.EnumSet.size, would you please try it?

        Paulex Yang added a comment -

        Spark, patch applied at revision r433135, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        spark shen added a comment -

        The patch looks fine

        Best regards

        Paulex Yang added a comment -

        Verified by Spark.


          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development