Harmony
  1. Harmony
  2. HARMONY-1211

[classlib][luni] new method noneOf(Class<E>) in java.util.EnumSet

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new method java.util.EnumSet.noneOf(Class<E>) but not
      implemented in Harmony(project luni). I will attach a patch soon.

      Best regards
      Spark Shen

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        6h 40m 1 Paulex Yang 17/Aug/06 08:48
        Resolved Resolved Closed Closed
        17h 34m 1 Paulex Yang 18/Aug/06 02:22
        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Paulex Yang added a comment -

        Verified by Spark.

        spark shen added a comment -

        Paulex, thank you for applying. The patch looks fine.

        Paulex Yang made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r432183, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        spark shen made changes -
        Field Original Value New Value
        Attachment Harmony-1211.diff [ 12339001 ]
        spark shen added a comment -

        Hi, I have attached the patch. Would you please try this patch?

        Best regards
        Spark Shen

        spark shen created issue -

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development