Harmony
  1. Harmony
  2. HARMONY-1210

[classlib][luni] new method in java.util.EnumMap

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new method public V put(K key, V value) in java.util.EnumMap but not
      implemented in Harmony(project luni).

        Activity

        spark shen created issue -
        spark shen added a comment -

        Would you please try this patch?

        Best regards
        Spark Shen

        spark shen made changes -
        Field Original Value New Value
        Attachment harmony-1210.diff [ 12338999 ]
        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        Paulex Yang added a comment -

        Spark, patch applied at revision r432185 with minor changes, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        spark shen added a comment -

        Thank you for applying. The patch looks as expected.

        Paulex Yang added a comment -

        Verified by Spark.

        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        7h 51m 1 Paulex Yang 17/Aug/06 10:07
        Resolved Resolved Closed Closed
        17h 15m 1 Paulex Yang 18/Aug/06 03:22

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development