Harmony
  1. Harmony
  2. HARMONY-1203

[classlib][luni] new constructor of java.util.EnumMap - EnumMap(Class<K>)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new constructor EnumMap(Class<K> keyType) in java.util.EnumMap but not
      implemented in Harmony.

      Spark shen
      Best regards

        Activity

        Paulex Yang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Paulex Yang added a comment -

        Verified by Spark.

        spark shen added a comment -

        The fix looks fine. Thank you.

        Best regards

        Paulex Yang made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Paulex Yang added a comment -

        Spark , patch applied at revision r431847 with minor changes, I removed the checkNull() invocation, because the NPE can be thrown natually, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        spark shen made changes -
        Field Original Value New Value
        Attachment harmony-1203.diff [ 12338931 ]
        spark shen added a comment -

        Would you please try this patch?

        Best regards
        Spark Shen

        spark shen created issue -

          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development