Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-9489

Eclipse instructions in BUILDING.txt don't work

Add voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments


    • Type: Bug
    • Status: Patch Available
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 2.7.0
    • Fix Version/s: None
    • Component/s: build
    • Labels:
    • Target Version/s:


      I have tried several times to import Hadoop trunk into Eclipse following the instructions in the BUILDING.txt file, but so far have not been able to get it to work.

      If I use a fresh install of Eclipse 4.2.2, Eclipse will complain about an undefined M2_REPO environment variable. I discovered that this is defined automatically by the M2Eclipse plugin, and think that the BUILDING.txt doc should be updated to explain this.

      After installing M2Eclipse I tried importing the code again, and now get over 2500 errors related to missing class dependencies. Many of these errors correspond to missing classes in the oah*.proto namespace, which makes me think that 'mvn eclipse:eclipse' is not triggering protoc.


        1. eclipse_hadoop_errors.txt
          451 kB
          Carl Steinbach
        2. error.log
          15 kB
          Tsuyoshi Ozawa
        3. HADOOP-9489.003.patch
          3 kB
          Chris Nauroth
        4. HADOOP-9489.004.patch
          2 kB
          Chris Nauroth
        5. HADOOP-9489.1.patch
          3 kB
          Chris Nauroth
        6. HADOOP-9489.2.patch
          3 kB
          Chris Nauroth



            • Assignee:
              cwsteinbach Carl Steinbach


              • Created:

                Issue deployment