Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-9334

Update netty version

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.0-beta, 3.0.0-alpha1
    • Fix Version/s: 2.1.0-beta
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      There are newer version available. HBase for example depends on the 3.5.9.
      Latest 3.5 is 3.5.11, there is the 3.6.3 as well.

      While there is no point in trying to have exactly the same version, things are more comfortable if the gap in version is minimal, as the dependency is client side as well (i.e. HBase has to choose a version anyway).

      Attached a patch for the branch 2.

      I haven't executed the unit tests, but HBase works ok with Hadoop on Netty 3.5.9.

        Attachments

        1. 9334.trunk.v1.patch
          3 kB
          Nicolas Liochon
        2. 9334.branch2.v1.patch
          3 kB
          Nicolas Liochon

          Issue Links

            Activity

              People

              • Assignee:
                nkeywal Nicolas Liochon
                Reporter:
                nkeywal Nicolas Liochon
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: