Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-8934

Shell command ls should include sort options

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: fs
    • Labels:
      None
    • Release Note:
      Options to sort output of fs -ls comment: -t (mtime), -S (size), -u (atime), -r (reverse)

      Description

      The shell command ls should include options to sort the output similar to the unix ls command. The following options seem appropriate:
      -t : sort by modification time
      -S : sort by file size
      -r : reverse the sort order
      -u : use access time rather than modification time for sort and display

      1. HADOOP-8934.patch
        71 kB
        Jonathan Allen
      2. HADOOP-8934.patch
        70 kB
        Jonathan Allen
      3. HADOOP-8934.patch
        69 kB
        Jonathan Allen
      4. HADOOP-8934.patch
        72 kB
        Jonathan Allen
      5. HADOOP-8934.patch
        74 kB
        Jonathan Allen
      6. HADOOP-8934.patch
        65 kB
        Jonathan Allen
      7. HADOOP-8934.patch
        68 kB
        Jonathan Allen
      8. HADOOP-8934.patch
        65 kB
        Jonathan Allen

        Issue Links

          Activity

          jonallen Jonathan Allen added a comment -

          Patch now ready for code review.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12550004/HADOOP-8934.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common:

          org.apache.hadoop.cli.TestCLI

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1651//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1651//console

          This message is automatically generated.

          jonallen Jonathan Allen added a comment -

          Fixing TestCLI failure

          jonallen Jonathan Allen added a comment -

          TestCLI failures resolved

          jonallen Jonathan Allen added a comment -

          Patch ready for code review

          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12550073/HADOOP-8934.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1654//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1654//console

          This message is automatically generated.

          daryn Daryn Sharp added a comment -

          Nice! I'm very interested in this patch. Cursory scan looks good, but I'll more thoroughly review next week.

          jonallen Jonathan Allen added a comment -

          Daryn - did you have a change to review this yet?

          daryn Daryn Sharp added a comment -

          I'm sorry for delay. I lost track of this jira... Comments:

          • Let's leave PathData alone to make the patch have more brevity and to prevent inconsistency. Another followup jira could switch all the commands to use accessors rather than fields.
          • I think the sort order isn't quite right, at least for size it looks backwards from the real ls.
          • Default sort should use PathData#compareTo.
          • If you haven't already, ensure the patch hasn't broken any of the TestHDFSCLI tests. You probably should add a few tests of your own. If nothing else it's easier to visualize if a command and output are correct.
          • Small nits regarding code guidelines:
            • please use spaces in conditionals, ex. "if (blah)" instead of "if(blah)"
            • cuddle the else clauses
            • try to stay within 80 char lines
          jonallen Jonathan Allen added a comment -

          actioning review comments

          jonallen Jonathan Allen added a comment -

          review comments actioned:

          • sort order for -S corrected
          • now using PathData.compareTo rather than Path
          • changes to PathData (& Command) reverted (and a MockFileSystem used in unit tests instead)

          I didn't know about TestHDFSCLI but have now confirmed change doesn't break any of the existing tests. I'll add some additional tests later this week.

          jonallen Jonathan Allen added a comment -

          Patch updated to add TestHDFSCLI test cases. I've added tests for default, size and mtime ordering but not atime as HDFS has a one hour granularity for this (if anyone can think of a way around this then feel free to suggest it).

          jonallen Jonathan Allen added a comment -

          review comments actioned so ready for another review

          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12554774/HADOOP-8934.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1815//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1815//console

          This message is automatically generated.

          jonallen Jonathan Allen added a comment -

          Daryn - did you get a chance to review the latest patch for this?

          daryn Daryn Sharp added a comment -

          Looks good! isOrderMtime is a bit misleading since it might be sorting by mtime or atime. I'd suggest isOrderByTime?

          Well I admire the thoroughness of the tests, please don't test the usage and description in your new tests since it duplicates the checks in testConf.xml. It'd be a pain to update two different tests in common for the same thing.

          jonallen Jonathan Allen added a comment -

          Review comments actioned:

          • isOrderMtime renamed as isOrderTime (also changed isShowAtime to isUseAtime to better reflect it's purpose).
          • usage and description unit tests removed

          Also updated the new FileSystemShell.apt.vm file to include the new options for the ls command.

          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12569285/HADOOP-8934.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2192//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2192//console

          This message is automatically generated.

          daryn Daryn Sharp added a comment -

          +1 Nice job!

          jonallen Jonathan Allen added a comment -

          Is there anything stopping this from being committed?

          jingzhao Jing Zhao added a comment -

          Hi Jonathan,

          The patch looks pretty good to me. The only minor nit is in the description of LS:

            public static final String DESCRIPTION =
              "List the contents that match the specified file pattern. If\n"
              + "path is not specified, the contents of /user/<currentUser>\n"
              + "will be listed. For a directory a list of its direct children\n"
              + "is returned (unless -" + OPTION_DIRECTORY + " option is specified).
          

          Looks like if the path is not specified, in trunk we cannot get the content of /user/<currentUser>? And if OPTION_RECURSIVE is specified, we will get more than direct children.

          jonallen Jonathan Allen added a comment -

          Jing,

          Does the following description look OK or have I misunderstood your concern?

          List the specified paths. If no path is specified then /user/<currentUser> shall be used as a default. If the specified path is a directory then its contents are returned (unless -d option is specified).

          brocknoland Brock Noland added a comment -

          Hi Jonathan Allen are you still working on this one?

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12569285/HADOOP-8934.patch
          against trunk revision .

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/3770//console

          This message is automatically generated.

          jonallen Jonathan Allen added a comment -

          Updated to build against latest trunk.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12640681/HADOOP-8934.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs:

          org.apache.hadoop.cli.TestCLI

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/3805//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/3805//console

          This message is automatically generated.

          jonallen Jonathan Allen added a comment -

          Fixed failing test

          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12640792/HADOOP-8934.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/3810//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/3810//console

          This message is automatically generated.

          aw Allen Wittenauer added a comment -

          Jonathan Allen, if you want to rebase this for trunk, let's get it committed.

          Thanks!

          jonallen Jonathan Allen added a comment -

          Updated for latest trunk.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12697349/HADOOP-8934.patch
          against trunk revision 7e42088.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          -1 findbugs. The patch appears to introduce 3 new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs:

          org.apache.hadoop.hdfs.TestEncryptionZonesWithKMS

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5634//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/5634//artifact/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/5634//artifact/patchprocess/newPatchFindbugsWarningshadoop-common.html
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5634//console

          This message is automatically generated.

          aw Allen Wittenauer added a comment -

          Committed to trunk.

          Thanks!

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #7053 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7053/)
          HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (aw: rev 30b797ee9df30260314eeadffc7d51492871b352)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/site/apt/FileSystemShell.apt.vm
          • hadoop-hdfs-project/hadoop-hdfs/src/test/resources/testHDFSConf.xml
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
            HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (missed file) (aw: rev 576459801c4e21effc4e3bca796527896b6e4f4b)
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #100 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/100/)
          HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (aw: rev 30b797ee9df30260314eeadffc7d51492871b352)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/resources/testHDFSConf.xml
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/site/apt/FileSystemShell.apt.vm
            HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (missed file) (aw: rev 576459801c4e21effc4e3bca796527896b6e4f4b)
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2050 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2050/)
          HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (aw: rev 30b797ee9df30260314eeadffc7d51492871b352)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/src/site/apt/FileSystemShell.apt.vm
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/resources/testHDFSConf.xml
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
            HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (missed file) (aw: rev 576459801c4e21effc4e3bca796527896b6e4f4b)
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #100 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/100/)
          HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (aw: rev 30b797ee9df30260314eeadffc7d51492871b352)

          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/site/apt/FileSystemShell.apt.vm
          • hadoop-hdfs-project/hadoop-hdfs/src/test/resources/testHDFSConf.xml
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
            HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (missed file) (aw: rev 576459801c4e21effc4e3bca796527896b6e4f4b)
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #834 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/834/)
          HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (aw: rev 30b797ee9df30260314eeadffc7d51492871b352)

          • hadoop-common-project/hadoop-common/src/site/apt/FileSystemShell.apt.vm
          • hadoop-hdfs-project/hadoop-hdfs/src/test/resources/testHDFSConf.xml
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
            HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (missed file) (aw: rev 576459801c4e21effc4e3bca796527896b6e4f4b)
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2032 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2032/)
          HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (aw: rev 30b797ee9df30260314eeadffc7d51492871b352)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/resources/testHDFSConf.xml
          • hadoop-common-project/hadoop-common/src/site/apt/FileSystemShell.apt.vm
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/CHANGES.txt
            HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (missed file) (aw: rev 576459801c4e21effc4e3bca796527896b6e4f4b)
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk-Java8 #97 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/97/)
          HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (aw: rev 30b797ee9df30260314eeadffc7d51492871b352)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/site/apt/FileSystemShell.apt.vm
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/resources/testHDFSConf.xml
            HADOOP-8934. Shell command ls should include sort options (Jonathan Allen via aw) (missed file) (aw: rev 576459801c4e21effc4e3bca796527896b6e4f4b)
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          ajisakaa Akira Ajisaka added a comment -

          Cherry-picking to branch-2 in order to cherry-pick HADOOP-10971 (Add -C option).

          ajisakaa Akira Ajisaka added a comment -

          Cherry-picked this to branch-2.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #7859 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7859/)
          Move HADOOP-8934 in CHANGES.txt from 3.0.0 to 2.8.0. (aajisaka: rev f889a49271f368e8d37a156fb1c568f6d286e88a)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #932 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/932/)
          Move HADOOP-8934 in CHANGES.txt from 3.0.0 to 2.8.0. (aajisaka: rev f889a49271f368e8d37a156fb1c568f6d286e88a)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk-Java8 #201 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/201/)
          Move HADOOP-8934 in CHANGES.txt from 3.0.0 to 2.8.0. (aajisaka: rev f889a49271f368e8d37a156fb1c568f6d286e88a)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2130 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2130/)
          Move HADOOP-8934 in CHANGES.txt from 3.0.0 to 2.8.0. (aajisaka: rev f889a49271f368e8d37a156fb1c568f6d286e88a)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #190 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/190/)
          Move HADOOP-8934 in CHANGES.txt from 3.0.0 to 2.8.0. (aajisaka: rev f889a49271f368e8d37a156fb1c568f6d286e88a)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk-Java8 #200 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/200/)
          Move HADOOP-8934 in CHANGES.txt from 3.0.0 to 2.8.0. (aajisaka: rev f889a49271f368e8d37a156fb1c568f6d286e88a)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2148 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2148/)
          Move HADOOP-8934 in CHANGES.txt from 3.0.0 to 2.8.0. (aajisaka: rev f889a49271f368e8d37a156fb1c568f6d286e88a)

          • hadoop-common-project/hadoop-common/CHANGES.txt

            People

            • Assignee:
              jonallen Jonathan Allen
              Reporter:
              jonallen Jonathan Allen
            • Votes:
              1 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development