Hadoop Common
  1. Hadoop Common
  2. HADOOP-8926

hadoop.util.PureJavaCrc32 cache hit-ratio is low for static data

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.3-alpha
    • Fix Version/s: 3.0.0, 2.0.3-alpha, 0.23.5
    • Component/s: util
    • Labels:
    • Environment:

      Ubuntu 10.10 i386

    • Release Note:
      Speed up Crc32 by improving the cache hit-ratio of hadoop.util.PureJavaCrc32

      Description

      While running microbenchmarks for HDFS write codepath, a significant part of the CPU fraction was consumed by the DataChecksum.update().

      The attached patch converts the static arrays in CRC32 into a single linear array for a performance boost in the inner loop.

      milli-seconds for 1Gig (16400 loop over a 64kb chunk)

      platform original cache-aware improvement
      x86 3894 2304 40.83
      x86_64 2131 1826 14

      The performance improvement on x86 is rather larger than the 64bit case, due to the extra register/stack pressure caused by the static arrays.

      A closer analysis of the PureJavaCrc32 JIT code shows the following assembly fragment

        0x40f1e345: mov    $0x184,%ecx
        0x40f1e34a: mov    0x4415b560(%ecx),%ecx  ;*getstatic T8_5
                                              ; - PureJavaCrc32::update@95 (line 61)
                                              ;   {oop('PureJavaCrc32')}
        0x40f1e350: mov    %ecx,0x2c(%esp)
      

      Basically, the static variables T8_0 through to T8_7 are being spilled to the stack because of register pressure. The x86_64 case has a lower likelihood of such pessimistic JIT code due to the increased number of registers.

      1. pure-crc32-cache-hit.patch
        6 kB
        Gopal V
      2. crc32-faster+test.patch
        13 kB
        Gopal V
      3. crc32-faster+readable.patch
        17 kB
        Gopal V

        Issue Links

          Activity

          Gopal V added a comment -

          main/ patch

          Gopal V added a comment -

          patch for the polynomial table gen, crc32 and crc32c

          Gopal V added a comment -

          The peak throughput (on my machine) went from 283 MB/s to 323 MB/s (according to TestPureJavaCrc32$PerformanceTest)

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12549014/crc32-faster%2Btest.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1623//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1623//console

          This message is automatically generated.

          Robert Joseph Evans added a comment -

          The change looks like a clean refactoring to me. The hard coded 256*X in several places in the code is not too hard to understand, but I think it would be cleaner if we could create a few static final values like

          private static final int T8_7_start = 256*7;
          ...
          private static final int T8_0_start = 0; //256*0
          ...
          localCrc = (T[T8_7_start + (c0 & 0xff)] ^ T[T8_6_start + (c1 & 0xff)])
             ^ (T[T8_5_start + (c2 & 0xff)] ^ T[T8_4_start + (c3 & 0xff)]);
          ...
          

          My only other comment is that we may now need to update the comment at the top of PureJavaCrc32.java. ~10x to 1.8x as fast does not seem accurate any more

          Gopal V added a comment -

          Sure, I will fix the readability of the patch by adding T8_[0-7]_start and re-run it through the JIT to make sure the class variables are getting inlined in the math.

          If that still results in a register splill, I will move them out of the loop as local final variables & re-submit a patch today.

          Gopal V added a comment -

          Reworking for readability of code

          Gopal V added a comment -

          Rewrite the core loop for readability & turn all loop locals into final variables.

          Modify the small loop into a switch statement (java tableswitch instruction)

          Gopal V added a comment -

          On x86_64 on an ec2 m1.xl (after changes)

          Performance Table (The unit is MB/sec)

          Num Bytes CRC32 PureJavaCrc32
          1 9.799 72.921
          2 18.850 177.113
          4 42.687 214.704
          8 70.552 318.484
          16 111.875 416.191
          32 153.779 496.209
          64 190.493 544.428
          128 215.851 564.414
          256 232.110 590.515
          512 240.359 581.974
          1024 244.682 597.676
          2048 246.642 599.621
          4096 249.438 604.247
          8192 249.247 605.547
          16384 249.524 606.494
          32768 249.508 602.449
          65536 250.977 604.064
          131072 249.678 597.944
          262144 249.505 603.270
          524288 250.805 602.656
          1048576 250.900 602.949
          2097152 250.137 601.563
          4194304 249.406 602.058
          8388608 249.937 598.310
          16777216 249.892 592.417
          Gopal V added a comment -

          Updated for readability and fewer instructions in the inner loop.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12549285/crc32-faster%2Breadable.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1632//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1632//console

          This message is automatically generated.

          Robert Joseph Evans added a comment -

          The changes look good to me +1. Gopal, what versions of Hadoop are you targeting with this change?

          Gopal V added a comment -

          The patches are on Hadoop 2.x (trunk) for now - will move it to branch-1.1 once it is baked in.

          Robert Joseph Evans added a comment -

          Thanks Gopal. I put this into trunk and branch-2.

          Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #2875 (See https://builds.apache.org/job/Hadoop-trunk-Commit/2875/)
          HADOOP-8926. hadoop.util.PureJavaCrc32 cache hit-ratio is low for static data (Gopal V via bobby) (Revision 1399005)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1399005
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32C.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestPureJavaCrc32.java
          Hudson added a comment -

          Integrated in Hadoop-Yarn-trunk #6 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/6/)
          HADOOP-8926. hadoop.util.PureJavaCrc32 cache hit-ratio is low for static data (Gopal V via bobby) (Revision 1399005)

          Result = FAILURE
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1399005
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32C.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestPureJavaCrc32.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1198 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1198/)
          HADOOP-8926. hadoop.util.PureJavaCrc32 cache hit-ratio is low for static data (Gopal V via bobby) (Revision 1399005)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1399005
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32C.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestPureJavaCrc32.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1228 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1228/)
          HADOOP-8926. hadoop.util.PureJavaCrc32 cache hit-ratio is low for static data (Gopal V via bobby) (Revision 1399005)

          Result = FAILURE
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1399005
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32C.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestPureJavaCrc32.java
          Tsz Wo Nicholas Sze added a comment -

          Gopal, Amazing works! There are 10% or more performance improvement from your patch.

          java.version = 1.6.0_35
          java.runtime.name = Java(TM) SE Runtime Environment
          java.runtime.version = 1.6.0_35-b10-428-11M3811
          java.vm.version = 20.10-b01-428
          java.vm.vendor = Apple Inc.
          java.vm.name = Java HotSpot(TM) 64-Bit Server VM
          java.vm.specification.version = 1.0
          java.specification.version = 1.6
          os.arch = x86_64
          os.name = Mac OS X
          os.version = 10.7.4

          Performance Table (The unit is MB/sec)

          Num Bytes CRC32 PureJavaCrc32_8926 PureJavaCrc32
          1 11.896 129.832 164.845
          2 24.097 192.742 210.266
          4 46.274 222.059 233.902
          8 82.332 488.716 438.514
          16 131.682 587.312 602.784
          32 187.265 796.510 760.628
          64 237.088 938.650 891.017
          128 264.795 1049.774 913.666
          256 291.785 1095.084 987.380
          512 298.590 1126.067 1002.899
          1024 305.349 1152.375 1040.211
          2048 309.342 1119.713 1033.258
          4096 309.162 1170.767 1047.746
          8192 321.775 1189.724 1053.065
          16384 320.457 1181.128 1060.138
          32768 324.524 1169.965 1050.610
          65536 322.380 1160.471 1053.854
          131072 315.983 1138.223 1009.193
          262144 324.293 1190.476 1020.782
          524288 316.003 1136.979 1015.389
          1048576 321.715 1081.465 1033.750
          2097152 318.330 1189.680 1072.054
          4194304 316.710 1138.496 1024.352
          8388608 315.701 1124.909 1030.505
          16777216 325.575 1154.724 1031.285
          Gopal V added a comment -

          Thanks Nicholas, this probably has future for improvement if we had ByteBuffers (direct) instead of byte[] arrays.

          I'm tracing the code-path from the network I/O to see if a nio fix can possibly get me bytebuffers direct.

          Meanwhile, If this is significant enough for a back-port, I can open a new ticket & port this patch to branch-1.1 (or is branch-1 the "live" one?).

          Tsz Wo Nicholas Sze added a comment -

          Sure, let's backport this to branch-1.

          Gopal V added a comment -

          Opened HADOOP-8971 as a backport of this to branch-1

          Robert Joseph Evans added a comment -

          I pulled this into branch-0.23 too.

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #415 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/415/)
          svn merge -c 1399005 FIXES: HADOOP-8926. hadoop.util.PureJavaCrc32 cache hit-ratio is low for static data (Gopal V via bobby) (Revision 1401803)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401803
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/PureJavaCrc32C.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestPureJavaCrc32.java

            People

            • Assignee:
              Gopal V
              Reporter:
              Gopal V
            • Votes:
              0 Vote for this issue
              Watchers:
              18 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development