Hadoop Common
  1. Hadoop Common
  2. HADOOP-8341

Fix or filter findbugs issues in hadoop-tools

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 0.23.3, 2.0.2-alpha
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      Now that the precommit build can test hadoop-tools we need to fix or filter the many findbugs warnings that are popping up in there.

      1. HADOOP-8341.txt
        13 kB
        Robert Joseph Evans
      2. HADOOP-8341.txt
        15 kB
        Robert Joseph Evans

        Activity

        Robert Joseph Evans added a comment -

        This is the breakdown of the existing findbugs issues.

        • Streaming - 7 (mostly returning internal data)
        • distcp - 2 (threading issues)
        • archives - 1 (casting Configuration to JobConf)
        • Rumen - 8 (returning internal data and serialization)
        • extras - 2 (some things should be marked final)
        Robert Joseph Evans added a comment -

        This patch fixes most of the findbugs issues, but also filters out a few of them where changes looked like they may impact the overall functionality of the code.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12525669/HADOOP-8341.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 javadoc. The javadoc tool appears to have generated 2 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        -1 release audit. The applied patch generated 1 release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-tools/hadoop-archives hadoop-tools/hadoop-distcp hadoop-tools/hadoop-extras hadoop-tools/hadoop-rumen hadoop-tools/hadoop-streaming:

        org.apache.hadoop.tools.mapred.TestUniformSizeInputFormat

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/941//testReport/
        Release audit warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/941//artifact/trunk/patchprocess/patchReleaseAuditProblems.txt
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/941//console

        This message is automatically generated.

        Robert Joseph Evans added a comment -

        Addressing the missing license statement in findbugs exclude file. The test passes for me locally. I think it is caused by running with an older version of an HDFS jar, so I am going to upload the new patch and see if that fixes it.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12525860/HADOOP-8341.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 javadoc. The javadoc tool appears to have generated 2 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-tools/hadoop-archives hadoop-tools/hadoop-distcp hadoop-tools/hadoop-extras hadoop-tools/hadoop-rumen hadoop-tools/hadoop-streaming.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/949//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/949//console

        This message is automatically generated.

        Robert Joseph Evans added a comment -

        The javadoc issues are unrelated, and are being covered by a separate JIRA. No tests were included because no functionality should have changed, just cleared up some findbugs issues for defensive programming.

        Tom White added a comment -

        +1

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2279 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2279/)
        HADOOP-8341. Fix or filter findbugs issues in hadoop-tools (bobby) (Revision 1335505)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1335505
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-tools/hadoop-archives/src/main/java/org/apache/hadoop/tools/HadoopArchives.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-distcp/src/main/java/org/apache/hadoop/tools/DistCp.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-extras/src/main/java/org/apache/hadoop/tools/Logalyzer.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/DeskewedJobTraceReader.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/JobConfPropertyNames.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/LoggedNetworkTopology.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/TraceBuilder.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/anonymization/WordListAnonymizerUtility.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/datatypes/NodeName.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/StreamJob.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2204 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2204/)
        HADOOP-8341. Fix or filter findbugs issues in hadoop-tools (bobby) (Revision 1335505)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1335505
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-tools/hadoop-archives/src/main/java/org/apache/hadoop/tools/HadoopArchives.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-distcp/src/main/java/org/apache/hadoop/tools/DistCp.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-extras/src/main/java/org/apache/hadoop/tools/Logalyzer.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/DeskewedJobTraceReader.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/JobConfPropertyNames.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/LoggedNetworkTopology.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/TraceBuilder.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/anonymization/WordListAnonymizerUtility.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/datatypes/NodeName.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/StreamJob.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2221 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2221/)
        HADOOP-8341. Fix or filter findbugs issues in hadoop-tools (bobby) (Revision 1335505)

        Result = ABORTED
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1335505
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-tools/hadoop-archives/src/main/java/org/apache/hadoop/tools/HadoopArchives.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-distcp/src/main/java/org/apache/hadoop/tools/DistCp.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-extras/src/main/java/org/apache/hadoop/tools/Logalyzer.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/DeskewedJobTraceReader.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/JobConfPropertyNames.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/LoggedNetworkTopology.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/TraceBuilder.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/anonymization/WordListAnonymizerUtility.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/datatypes/NodeName.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/StreamJob.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #252 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/252/)
        svn merge -c 1335505 FIXES: HADOOP-8341. Fix or filter findbugs issues in hadoop-tools (bobby) (Revision 1335507)

        Result = UNSTABLE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1335507
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-archives/src/main/java/org/apache/hadoop/tools/HadoopArchives.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-distcp/src/main/java/org/apache/hadoop/tools/DistCp.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-extras/src/main/java/org/apache/hadoop/tools/Logalyzer.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/dev-support
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/dev-support/findbugs-exclude.xml
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/DeskewedJobTraceReader.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/JobConfPropertyNames.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/LoggedNetworkTopology.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/TraceBuilder.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/anonymization/WordListAnonymizerUtility.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/datatypes/NodeName.java
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-streaming/dev-support
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-streaming/dev-support/findbugs-exclude.xml
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-streaming/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/StreamJob.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1039 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1039/)
        HADOOP-8341. Fix or filter findbugs issues in hadoop-tools (bobby) (Revision 1335505)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1335505
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-tools/hadoop-archives/src/main/java/org/apache/hadoop/tools/HadoopArchives.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-distcp/src/main/java/org/apache/hadoop/tools/DistCp.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-extras/src/main/java/org/apache/hadoop/tools/Logalyzer.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/DeskewedJobTraceReader.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/JobConfPropertyNames.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/LoggedNetworkTopology.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/TraceBuilder.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/anonymization/WordListAnonymizerUtility.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/datatypes/NodeName.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/StreamJob.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1074 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1074/)
        HADOOP-8341. Fix or filter findbugs issues in hadoop-tools (bobby) (Revision 1335505)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1335505
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-tools/hadoop-archives/src/main/java/org/apache/hadoop/tools/HadoopArchives.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-distcp/src/main/java/org/apache/hadoop/tools/DistCp.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-extras/src/main/java/org/apache/hadoop/tools/Logalyzer.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/DeskewedJobTraceReader.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/JobConfPropertyNames.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/LoggedNetworkTopology.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/TraceBuilder.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/anonymization/WordListAnonymizerUtility.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-rumen/src/main/java/org/apache/hadoop/tools/rumen/datatypes/NodeName.java
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/dev-support/findbugs-exclude.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/pom.xml
        • /hadoop/common/trunk/hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/StreamJob.java

          People

          • Assignee:
            Robert Joseph Evans
            Reporter:
            Robert Joseph Evans
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development