Hadoop Common
  1. Hadoop Common
  2. HADOOP-8140

dfs -getmerge should process its argments better

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.23.2
    • Component/s: None
    • Labels:
      None

      Description

      The command only works if its argument is a directory
      If the argement is a file or a wildcard, it does nothing without any message.
      If not arguments are given, the command fails with a stack dump.

      The improved version should:
      – produce an error message in case it cannot perform meaningful action (no argument, or no matching files)
      – copy the files specified by a wildcard expresstion. (A single file is special case of this).

      1. HADOOP-8140-3.patch
        9 kB
        Daryn Sharp
      2. HADOOP-8140-2.patch
        8 kB
        Daryn Sharp
      3. HADOOP-8140.patch
        6 kB
        Daryn Sharp
      4. Hadoop-1004_1.patch
        4 kB
        Mahadev konar

        Issue Links

          Activity

          Mahadev konar added a comment -

          this patch fixes argument processing for getmerge and changes its documentation to concatinating files rather than merging.

          Mahadev konar added a comment -

          Assigning this issue to Rob as I wont be working on it any longer.

          Daryn Sharp added a comment -

          Handle files and directories in a manner consistent with other commands instead of silently skipping files. Wildcard problem is fixed by accepting multiple args.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12517110/HADOOP-8140.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.fs.viewfs.TestViewFsTrash
          org.apache.hadoop.fs.TestFsShellCopy

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/671//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/671//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          New tests failed due to non-deterministic behavior of directory listing order across operating systems.

          Robert Joseph Evans added a comment -

          Is there a JIRA to fix the tests?

          Tsz Wo Nicholas Sze added a comment -

          How about we sort the outputs before comparing them in the test?

          Daryn Sharp added a comment -

          Yes, I think order is quite important for this command, so I'll be sorting the expanded dirs to ensure deterministic behavior.

          Daryn Sharp added a comment -

          Sort files within a directory to maintain deterministic behavior.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12517127/HADOOP-8140-2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          -1 findbugs. The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/672//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/672//artifact/trunk/hadoop-common-project/patchprocess/newPatchFindbugsWarningshadoop-common.html
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/672//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          Add equals/hashcode to balance compareTo.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12517250/HADOOP-8140-3.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.ipc.TestRPCCallBenchmark

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/680//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/680//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          Patch is unrelated to RPC benchmark failure of:

          Caused by: java.lang.RuntimeException: IPC server unable to read call parameters: readObject can't find class java.lang.String

          Robert Joseph Evans added a comment -

          Thanks Daryn. I just put this into trunk, 0.23 and 0.23.2

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1851 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1851/)
          HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297771)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297771
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #649 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/649/)
          svn merge -c 1297771 trunk to branch-0.23 FIXES: HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297773)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297773
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #638 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/638/)
          svn merge -c 1297771 trunk to branch-0.23 FIXES: HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297773)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297773
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #1918 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1918/)
          HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297771)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297771
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1844 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1844/)
          HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297771)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297771
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #648 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/648/)
          svn merge -c 1297771 trunk to branch-0.23 FIXES: HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297773)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297773
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #190 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/190/)
          svn merge -c 1297771 trunk to branch-0.23 FIXES: HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297773)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297773
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #977 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/977/)
          HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297771)

          Result = FAILURE
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297771
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Build #218 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/218/)
          svn merge -c 1297771 trunk to branch-0.23 FIXES: HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297773)

          Result = FAILURE
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297773
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1012 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1012/)
          HADOOP-8140. dfs -getmerge should process its argments better (Daryn Sharp via bobby) (Revision 1297771)

          Result = FAILURE
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297771
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/CopyCommands.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/PathData.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFsShellCopy.java

            People

            • Assignee:
              Daryn Sharp
              Reporter:
              arkady borkovsky
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development