Hadoop Common
  1. Hadoop Common
  2. HADOOP-7984

Add hadoop --loglevel option to change log level

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.7.0
    • Component/s: scripts
    • Labels:
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      It would be helpful if bin/hadoop had --loglevel option to change the log level. Currently users need to set an env variable or prefix the command (eg "HADOOP_ROOT_LOGGER=DEBUG,console hadoop distcp") which isn't very user friendly.

      1. HADOOP-7984.patch
        4 kB
        Allen Wittenauer
      2. HADOOP-7984.patch
        17 kB
        Akira AJISAKA
      3. HADOOP-7984.3.patch
        16 kB
        Akira AJISAKA
      4. HADOOP-7984-branch-2.patch
        13 kB
        Akira AJISAKA
      5. HADOOP-7984.4.patch
        17 kB
        Akira AJISAKA
      6. HADOOP-7984-branch-2.2.patch
        17 kB
        Akira AJISAKA
      7. HADOOP-7984.5.patch
        17 kB
        Akira AJISAKA
      8. HADOOP-7984-branch-2.3.patch
        17 kB
        Akira AJISAKA

        Issue Links

          Activity

          Allen Wittenauer added a comment - - edited

          With the common code shell path in trunk, adding this functionality is fairly trivial.

          That said, I've already co-opted --debug for debugging the actual shell scripts as part of one of the follow-ons for HADOOP-9902. Since this isn't out in the wild yet, we can certainly move the shell's --debug into something else (--shelldebug?) and take back it back for usage here, which is much more likely to get used.

          I'll work up a patch tomorrow.

          Allen Wittenauer added a comment -

          What is the expected behavior if a user sets up xyz_OPTS to have hadoop.root.logger manually set? Should the code honor that setting and leave it alone or should it try to find it and replace it if --debug or --verbose is set?

          Allen Wittenauer added a comment - - edited
          • Changes the default loggers to WARN,console & WARN,RFA
          • Changes --debug to take parameters (--debug shell, --debug java, --debug java shell, --debug shell java) to activate debugging for the shell code and/or set DEBUG as the first param in the logger env vars.
          • --verbose added which changes the first param in the log4j params to INFO
          Allen Wittenauer added a comment -

          Also, wrt my question, this patch opts to leave the setting in _OPTS alone.

          Allen Wittenauer added a comment -

          OK, correct patch this time.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12668894/HADOOP-7984.patch
          against trunk revision 8008f0e.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common:

          org.apache.hadoop.crypto.random.TestOsSecureRandom

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/4733//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4733//console

          This message is automatically generated.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12668904/HADOOP-7984.patch
          against trunk revision 8008f0e.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common:

          org.apache.hadoop.crypto.random.TestOsSecureRandom

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/4734//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4734//console

          This message is automatically generated.

          Allen Wittenauer added a comment -

          We had a discussion about this in the office today. One suggestion was that --debug and --verbose is really the wrong operation here. Perhaps it would be better if it was --loglevel. This way, one could do, for example:

          hdfs --loglevel INFO foo
          hdfs --loglevel WARN blah
          hdfs --loglevel DEBUG blah
          

          etc...

          Rather than tying specific values to an option, make it free form. This also gets rid of the 'awkwardness' of having --debug being used for both shell and java components.

          Akira AJISAKA added a comment -

          Perhaps it would be better if it was --loglevel.

          That's a good idea!

          Akira AJISAKA added a comment -

          Attaching a patch to add "--loglevel" option. I verified it worked on Linux. However, I have not tried it on Windows yet since I don't have Windows environment.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12670934/HADOOP-7984.patch
          against trunk revision ef784a2.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4798//console

          This message is automatically generated.

          Akira AJISAKA added a comment -

          The patch command can not apply the patch because .cmd files have CR+LF but the patch, created by git diff, has no CR+LF. Reviewers can use "git apply -p0 /path/to/patch" to apply the patch locally.

          Allen Wittenauer added a comment -

          Hopefully Chris Nauroth won't mind me adding him to this JIRA so that he can look over the batch code.

          It looks good, with only one issue that I saw. We should avoid adding more of the crazy project split variables. So please drop the HADOOP_MAPRED_LOGLEVEL and YARN_LOGLEVEL bits and just use HADOOP_LOGLEVEL everywhere. Those per-project vars are a source of continual problems out in the real world, and we definitely don't want to propagate more of them! (Easy example: 'hadoop jar' and 'yarn jar' work differently depending upon what is in the various *-env.sh, despite doing essentially the same thing...)

          I saw that you changed the log level for the security audit log, but I don't think it has anything but INFO coded. It's a coin toss whether or not we should actually change that.

          Also, one of the stated goals of this JIRA was to change the default from INFO up to WARN. Is this something we still want to do?

          Comments from the crowd would be good...

          Thanks!

          Akira AJISAKA added a comment -

          Thanks Allen for comments.

          So please drop the HADOOP_MAPRED_LOGLEVEL and YARN_LOGLEVEL bits and just use HADOOP_LOGLEVEL everywhere.

          I'll drop them in the next patch.

          I saw that you changed the log level for the security audit log, but I don't think it has anything but INFO coded.

          Agree, I'll drop the change.

          Also, one of the stated goals of this JIRA was to change the default from INFO up to WARN. Is this something we still want to do?

          I just want to add "--loglevel" option because adding a new option is compatible. I'm thinking it would be better to create a separate jira for changing the default log level (i.e. incompatible change).

          Allen Wittenauer added a comment -

          It's probably worth noting that if this is to go into branch-2, you'll need to make two separate patches anyway since branch-2 still has the incredibly crappy shell code. So an incompatible change for trunk is totally ok.

          Akira AJISAKA added a comment -

          Attaching patches for trunk and branch-2.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12671186/HADOOP-7984-branch-2.patch
          against trunk revision dff95f7.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4807//console

          This message is automatically generated.

          Akira AJISAKA added a comment -

          Updated the description. I'll file a separate jira to change the default log level.

          Akira AJISAKA added a comment -

          Filed HADOOP-11134 for changing the default log level.

          Chris Nauroth added a comment -

          Akira, thanks for working on this, and thank you for including changes for both bash and cmd. Allen, thanks for the ping.

          The current patch's cmd scripts aren't working. The --loglevel argument is not getting stripped off before passing to the java.exe call. Since java.exe doesn't recognize --loglevel as an argument, it aborts immediately.

          To fix this, you'll need to change 2 points in the code that strip away "pre-processed" command line arguments. Unfortunately, this is code duplicated across the 4 main entry points (perhaps unavoidable due to cmd limitations). You'll need to make this change in hadoop.cmd, hdfs.cmd, mapred.cmd and yarn.cmd. Do a find on "--config", and basically you can clone whatever is done for --config and do the same for --loglevel. The first point will be near the top of the file, and this is done to make sure command selection can find the command in the first position. The second point will be in a subroutine named make_command_arguments, and this is done to prevent passing the argument to java.exe.

          I see mapred.cmd is setting HADOOP_LOGLEVEL. I expect you won't need to do that, because hadoop-config.cmd will get called through mapred.cmd. Same thing for yarn-config.cmd. It calls hadoop-config.cmd, so you can drop this part of the change.

          Also, I have a small suggestion on the 4 documentation files that have this line:

          +| --loglevel loglevel | Overwrites the log level. Default is INFO.
          

          Can we also briefly list the valid log level settings, just in case the user isn't familiar with the logging libraries?

          Thanks again. I can take it for another test run when a new patch is ready.

          Akira AJISAKA added a comment -

          Thanks Chris Nauroth for telling me how to fix it in windows. Updated the patch.
          To reduce duplicate work, I'll prepare a patch for branch-2 after Chris and Allen say okay.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12672612/HADOOP-7984.4.patch
          against trunk revision 03db9cc8.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4850//console

          This message is automatically generated.

          Chris Nauroth added a comment -

          Nice work, Akira! I tested patch v4, calling all 4 main entry points, with and without a --loglevel option. I did find one more spot that needs a change. In yarn-env.cmd, we have this code:

          if not defined YARN_ROOT_LOGGER (
            set YARN_ROOT_LOGGER=INFO,console
          )
          

          It needs to be changed to this:

          if not defined YARN_ROOT_LOGGER (
            set YARN_ROOT_LOGGER=%HADOOP_LOGLEVEL%,console
          )
          

          I'm +1 for the trunk patch after that small change. However, I should mention that I didn't review the bash changes. Allen Wittenauer, are you ready to +1 on the bash side, or do you have more feedback?

          After a branch-2 patch is available, I'd like to retest there.

          Allen Wittenauer added a comment -

          Sorry, I've been out of town. The patch no longer applies, but it did apply enough that it works for the Unix-side of the house for me to test. One thing that I'm sort of wondering about... should we protect users from giving bad values? i.e., 'warn' vs WARN?

          Other than that open question (which, really, doesn't matter either way to me), I'm +1.

          Akira AJISAKA added a comment -

          Thanks Chris Nauroth and Allen Wittenauer for testing!
          v4 patch already includes the change.

          diff --git hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          index 3329f8f..d863c1e 100644
          --- hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          +++ hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          @@ -42,7 +42,7 @@ if not defined YARN_POLICYFILE (
           )
           
           if not defined YARN_ROOT_LOGGER (
          -  set YARN_ROOT_LOGGER=INFO,console
          +  set YARN_ROOT_LOGGER=%HADOOP_LOGLEVEL%,console
           )
          

          One thing that I'm sort of wondering about... should we protect users from giving bad values? i.e., 'warn' vs WARN?

          I'm thinking it's not necessarily required to protect users from giving bad values, however, it's a good idea. I'll appreciate someone file a jira to do this.

          I'll prepare the patch for branch-2. Thanks again.

          Chris Nauroth added a comment -

          v4 patch already includes the change.

          You're right. I bet I just didn't deploy this file correctly during my test run. Sorry for the confusion.

          Akira AJISAKA added a comment -

          Attaching a patch for branch-2.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12674696/HADOOP-7984-branch-2.2.patch
          against trunk revision 5faaba0.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4921//console

          This message is automatically generated.

          Akira AJISAKA added a comment -

          Attaching a patch for trunk.

          Akira AJISAKA added a comment -

          Attaching a patch for branch-2.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12681196/HADOOP-7984-branch-2.3.patch
          against trunk revision b0a9cd3.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5073//console

          This message is automatically generated.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12681196/HADOOP-7984-branch-2.3.patch
          against trunk revision b0a9cd3.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5074//console

          This message is automatically generated.

          Chris Nauroth added a comment -

          I committed this to trunk and branch-2. Akira AJISAKA, thank you for contributing the patch. Allen Wittenauer, thank you for code reviewing. I'm looking forward to using this!

          Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #6531 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6531/)
          HADOOP-7984. Add hadoop --loglevel option to change log level. Contributed by Aikira AJISAKA. (cnauroth: rev 0abb973f0998ab70e5d3597fcc7ea29ca4d6b583)

          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
          • hadoop-mapreduce-project/bin/mapred-config.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.cmd
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/site/apt/MapredCommands.apt.vm
          • hadoop-mapreduce-project/conf/mapred-env.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.sh
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs.cmd
          • hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          • hadoop-yarn-project/hadoop-yarn/bin/yarn-config.sh
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site/src/site/apt/YarnCommands.apt.vm
          • hadoop-yarn-project/hadoop-yarn/bin/yarn
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop
          • hadoop-hdfs-project/hadoop-hdfs/src/site/apt/HDFSCommands.apt.vm
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/site/apt/CommandsManual.apt.vm
          • hadoop-mapreduce-project/bin/mapred.cmd
          • hadoop-yarn-project/hadoop-yarn/bin/yarn.cmd
          • hadoop-mapreduce-project/bin/mapred
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop.cmd
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #4 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/4/)
          HADOOP-7984. Add hadoop --loglevel option to change log level. Contributed by Aikira AJISAKA. (cnauroth: rev 0abb973f0998ab70e5d3597fcc7ea29ca4d6b583)

          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.cmd
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs.cmd
          • hadoop-hdfs-project/hadoop-hdfs/src/site/apt/HDFSCommands.apt.vm
          • hadoop-mapreduce-project/bin/mapred.cmd
          • hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          • hadoop-mapreduce-project/bin/mapred-config.sh
          • hadoop-mapreduce-project/bin/mapred
          • hadoop-yarn-project/hadoop-yarn/bin/yarn-config.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop.cmd
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/site/apt/MapredCommands.apt.vm
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • hadoop-mapreduce-project/conf/mapred-env.cmd
          • hadoop-yarn-project/hadoop-yarn/bin/yarn
          • hadoop-common-project/hadoop-common/src/site/apt/CommandsManual.apt.vm
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site/src/site/apt/YarnCommands.apt.vm
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.sh
          • hadoop-yarn-project/hadoop-yarn/bin/yarn.cmd
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #742 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/742/)
          HADOOP-7984. Add hadoop --loglevel option to change log level. Contributed by Aikira AJISAKA. (cnauroth: rev 0abb973f0998ab70e5d3597fcc7ea29ca4d6b583)

          • hadoop-mapreduce-project/conf/mapred-env.cmd
          • hadoop-yarn-project/hadoop-yarn/bin/yarn
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-yarn-project/hadoop-yarn/bin/yarn-config.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.cmd
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/site/apt/MapredCommands.apt.vm
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • hadoop-mapreduce-project/bin/mapred.cmd
          • hadoop-mapreduce-project/bin/mapred
          • hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop.cmd
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site/src/site/apt/YarnCommands.apt.vm
          • hadoop-hdfs-project/hadoop-hdfs/src/site/apt/HDFSCommands.apt.vm
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.sh
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs.cmd
          • hadoop-mapreduce-project/bin/mapred-config.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop
          • hadoop-yarn-project/hadoop-yarn/bin/yarn.cmd
          • hadoop-common-project/hadoop-common/src/site/apt/CommandsManual.apt.vm
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #4 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/4/)
          HADOOP-7984. Add hadoop --loglevel option to change log level. Contributed by Aikira AJISAKA. (cnauroth: rev 0abb973f0998ab70e5d3597fcc7ea29ca4d6b583)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site/src/site/apt/YarnCommands.apt.vm
          • hadoop-mapreduce-project/conf/mapred-env.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.cmd
          • hadoop-yarn-project/hadoop-yarn/bin/yarn-config.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop.cmd
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs.cmd
          • hadoop-mapreduce-project/bin/mapred-config.sh
          • hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/site/apt/MapredCommands.apt.vm
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.sh
          • hadoop-yarn-project/hadoop-yarn/bin/yarn
          • hadoop-hdfs-project/hadoop-hdfs/src/site/apt/HDFSCommands.apt.vm
          • hadoop-mapreduce-project/bin/mapred
          • hadoop-yarn-project/hadoop-yarn/bin/yarn.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop
          • hadoop-common-project/hadoop-common/src/site/apt/CommandsManual.apt.vm
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
          • hadoop-mapreduce-project/bin/mapred.cmd
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #1932 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1932/)
          HADOOP-7984. Add hadoop --loglevel option to change log level. Contributed by Aikira AJISAKA. (cnauroth: rev 0abb973f0998ab70e5d3597fcc7ea29ca4d6b583)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/site/apt/MapredCommands.apt.vm
          • hadoop-yarn-project/hadoop-yarn/bin/yarn.cmd
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site/src/site/apt/YarnCommands.apt.vm
          • hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.sh
          • hadoop-mapreduce-project/conf/mapred-env.cmd
          • hadoop-common-project/hadoop-common/src/site/apt/CommandsManual.apt.vm
          • hadoop-hdfs-project/hadoop-hdfs/src/site/apt/HDFSCommands.apt.vm
          • hadoop-mapreduce-project/bin/mapred
          • hadoop-mapreduce-project/bin/mapred.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.cmd
          • hadoop-yarn-project/hadoop-yarn/bin/yarn-config.sh
          • hadoop-yarn-project/hadoop-yarn/bin/yarn
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
          • hadoop-mapreduce-project/bin/mapred-config.sh
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #1956 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1956/)
          HADOOP-7984. Add hadoop --loglevel option to change log level. Contributed by Aikira AJISAKA. (cnauroth: rev 0abb973f0998ab70e5d3597fcc7ea29ca4d6b583)

          • hadoop-mapreduce-project/conf/mapred-env.cmd
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop
          • hadoop-common-project/hadoop-common/src/site/apt/CommandsManual.apt.vm
          • hadoop-mapreduce-project/bin/mapred
          • hadoop-yarn-project/hadoop-yarn/bin/yarn
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site/src/site/apt/YarnCommands.apt.vm
          • hadoop-yarn-project/hadoop-yarn/bin/yarn.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/site/apt/MapredCommands.apt.vm
          • hadoop-mapreduce-project/bin/mapred-config.sh
          • hadoop-yarn-project/hadoop-yarn/bin/yarn-config.sh
          • hadoop-hdfs-project/hadoop-hdfs/src/site/apt/HDFSCommands.apt.vm
          • hadoop-mapreduce-project/bin/mapred.cmd
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop.cmd
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk-Java8 #4 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/4/)
          HADOOP-7984. Add hadoop --loglevel option to change log level. Contributed by Aikira AJISAKA. (cnauroth: rev 0abb973f0998ab70e5d3597fcc7ea29ca4d6b583)

          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/site/apt/MapredCommands.apt.vm
          • hadoop-yarn-project/hadoop-yarn/bin/yarn
          • hadoop-yarn-project/hadoop-yarn/bin/yarn.cmd
          • hadoop-mapreduce-project/conf/mapred-env.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.cmd
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop-config.sh
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop.cmd
          • hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs.cmd
          • hadoop-common-project/hadoop-common/src/site/apt/CommandsManual.apt.vm
          • hadoop-yarn-project/hadoop-yarn/conf/yarn-env.cmd
          • hadoop-mapreduce-project/bin/mapred
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-mapreduce-project/bin/mapred.cmd
          • hadoop-yarn-project/hadoop-yarn/bin/yarn-config.sh
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site/src/site/apt/YarnCommands.apt.vm
          • hadoop-common-project/hadoop-common/src/main/bin/hadoop
          • hadoop-hdfs-project/hadoop-hdfs/src/site/apt/HDFSCommands.apt.vm
          • hadoop-mapreduce-project/bin/mapred-config.sh

            People

            • Assignee:
              Akira AJISAKA
              Reporter:
              Eli Collins
            • Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development