Hadoop Common
  1. Hadoop Common
  2. HADOOP-7955

hadoop 1.0.0 debian installer : hadoop-setup-conf.sh fails on chownsc

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.0.0
    • Fix Version/s: None
    • Component/s: scripts

      Description

      install hadoop_1.0.0-1_i386.deb ("dpkg -i hadoop_1.0.0-1_i386.deb") - OK
      run hadoop-setup-conf.sh and accept defaults
      script fails with three lines of "chown: invalid user: `mr:hadoop'"
      followed by configuration setup is completed run hadoop-setup-hdfs.sh
      hadoop-setup-hdfs.sh fails with permission errors in the log and run directories

        Activity

        Allen Wittenauer added a comment -

        Closing as won't fix. We no longer ship packaged versions.

        Jean-Marc Spaggiari added a comment -

        Issue is still there in 1.0.3.

        This issue is unassigned, does it mean no-one is looking into it?

        Seems that we can still install using --mapreduce-user=mapred option but I have not tried yet.

        I might give it a try later today. But reverting the installation when it fails is long.

        Alain RODRIGUEZ added a comment -

        Is this going to be resolved fast or should we use the tar.gz files and configure hadoop "by hand" ?

        hanasaki jiji added a comment -

        bump - I have some time to work on this if the current .deb project owner would contact me.

        Arpit Gupta added a comment -

        can you also add the permissions errors you saw. Will help in debugging where the issue is.

        hanasaki jiji added a comment -

        yes - all was run as root : .sh scripts and the dpk -i install

        Arpit Gupta added a comment -

        we should change the default mapred user to 'mapred' instead of 'mr' in these scripts. Also did you run these scripts as user root?

        The various setup scripts need to be executed by user root.


          People

          • Assignee:
            Unassigned
            Reporter:
            hanasaki jiji
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development