Hadoop Common
  1. Hadoop Common
  2. HADOOP-7917

compilation of protobuf files fails in windows/cygwin

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.1, 0.24.0
    • Fix Version/s: 0.23.1
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      HADOOP-7899 & HDFS-2511 introduced compilation of proto files as part of the build.

      Such compilation is failing in windows/cygwin

      1. HADOOP-7917.patch
        6 kB
        Alejandro Abdelnur

        Issue Links

          Activity

          Alejandro Abdelnur created issue -
          Alejandro Abdelnur made changes -
          Field Original Value New Value
          Link This issue relates to HADOOP-7899 [ HADOOP-7899 ]
          Alejandro Abdelnur made changes -
          Link This issue relates to HDFS-2511 [ HDFS-2511 ]
          Alejandro Abdelnur added a comment -

          changing script that compiles proto files to handle cywin and windows version of protoc which does not handle UNIX style paths.

          Note that hadoop-yarn-common is failing in windows but this is not related to the proto compilation but to the saveVersion.sh script, MAPREDUCE-3540 .

          Alejandro Abdelnur made changes -
          Attachment HADOOP-7917.patch [ 12507204 ]
          Alejandro Abdelnur made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Alejandro Abdelnur added a comment -

          patch tested on win7, osx, ubuntu

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12507204/HADOOP-7917.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/471//console

          This message is automatically generated.

          Uma Maheswara Rao G added a comment -

          Just verified the patch, it works fine for me except mapred compilation failure due to saveVersion.sh problem.
          mvn eclipse:eclipse also works fine for common and hdfs. Also imported into eclipse.

          Thanks Alejandro, for the patch. Looks good to me.

          +1 from my side.

          Why patch command failed in Jenkins? do you have idea? ( is it because of cross projects? )

          Mahadev konar added a comment -

          +1 the patch looks good.

          Ravi Teja Ch N V added a comment -

          Thanks for the patch Alejandro, it works.

          Alejandro Abdelnur added a comment -

          committed to trunk and branch-0.23

          Alejandro Abdelnur made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Hadoop Flags Reviewed [ 10343 ]
          Resolution Fixed [ 1 ]
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #283 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/283/)
          Merge -r 1214789:1214790 from trunk to branch. FIXES: HADOOP-7917

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1214792
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/pom.xml
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #306 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/306/)
          Merge -r 1214789:1214790 from trunk to branch. FIXES: HADOOP-7917

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1214792
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/pom.xml
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #294 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/294/)
          Merge -r 1214789:1214790 from trunk to branch. FIXES: HADOOP-7917

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1214792
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/pom.xml
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #109 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/109/)
          Merge -r 1214789:1214790 from trunk to branch. FIXES: HADOOP-7917

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1214792
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/pom.xml
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Build #129 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/129/)
          Merge -r 1214789:1214790 from trunk to branch. FIXES: HADOOP-7917

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1214792
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/pom.xml
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Uma Maheswara Rao G added a comment -

          Hi Alejandro,

          looks CHANGES.txt has typo mistake.

          HADOOP_7917. compilation of protobuf files fails in windows/cygwin. (tucu)

          issue id should have "-" instead of "_".

          Thanks
          Uma

          Alejandro Abdelnur added a comment -

          Uma,

          Thanks for pointing this out, I'll piggyback on the next commit I do to fix the typo.

          Alejandro

          Alejandro Abdelnur made changes -
          Fix Version/s 0.24.0 [ 12317652 ]
          Arun C Murthy made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Jinho Lee added a comment -

          Hello, I downloaded 0.24.0 and tried to build under Windows/Cygwin.
          Proto file compilation still seems to fail. I'm running mvn from within Cygwin though, not windows command prompt.
          And if I switch around the true and false logic for IS_WIN variable, it works fine.

          Is this by design?? Your clarification would be much helpful!!

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          5m 20s 1 Alejandro Abdelnur 13/Dec/11 16:37
          Patch Available Patch Available Resolved Resolved
          1d 22h 10m 1 Alejandro Abdelnur 15/Dec/11 14:47
          Resolved Resolved Closed Closed
          80d 12h 1m 1 Arun C Murthy 05/Mar/12 02:49

            People

            • Assignee:
              Alejandro Abdelnur
              Reporter:
              Alejandro Abdelnur
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development