Hadoop Common
  1. Hadoop Common
  2. HADOOP-7863

Apply HADOOP-7424 "Log an error if the topology script doesn't handle multiple args" to 0.23 branch

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.1
    • Component/s: None
    • Labels:
      None

      Description

      Merging HADOOP-7777 to 0.23.1 fails because this (minor) patch isn't in there. Rather than generate a new patch for 0.23.1, it would be easier to apply the existing patch to the 0.23.x branch and move the change log entries

        Issue Links

          Activity

          Eli Collins added a comment -

          +1 sounds good

          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #222 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/222/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207611
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/ScriptBasedMapping.java
          Steve Loughran added a comment -

          Existing patch applied; only conflict was in CHANGES.TXT

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #219 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/219/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207611
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/ScriptBasedMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #1405 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1405/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207614
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1331 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1331/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207614
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #233 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/233/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207611
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/ScriptBasedMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1355 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1355/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207614
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #92 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/92/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207611
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/ScriptBasedMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #879 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/879/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207614
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Build #108 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/108/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207611
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/ScriptBasedMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #912 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/912/)
          HADOOP-7863: apply HADOOP-7424 to 0.23.1

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1207614
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          Arun C Murthy added a comment -

          Closing as duplicate of HADOOP-7424, mucks up release notes and CHANGES.txt.


            People

            • Assignee:
              Steve Loughran
              Reporter:
              Steve Loughran
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 0.5h
                0.5h
                Remaining:
                Remaining Estimate - 0.5h
                0.5h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development