Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.23.0
    • Fix Version/s: None
    • Component/s: scripts
    • Labels:
      None
    • Environment:

      OS/X, no JAVA_HOME set, tarball installation

      Description

      you can't start the balance as it tries to call bin/hadoop-daemon.sh, which isn't there:

      hadoop-0.23.0 slo$ sbin/start-balancer.sh 
      sbin/start-balancer.sh: line 25: /Users/slo/Java/Hadoop/versions/hadoop-0.23.0/libexec/../bin/hadoop-daemon.sh: No such file or directory
      hadoop-0.23.0 slo$ 
      

        Issue Links

          Activity

          Steve Loughran added a comment -

          also applies to sbin/stop-balancer.sh

          Steve Loughran added a comment -

          resolving as duplicate of HDFS-3165 (technically that duplicates this one, but the patch is in the later JIRA...)


            People

            • Assignee:
              Unassigned
              Reporter:
              Steve Loughran
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development