Hadoop Common
  1. Hadoop Common
  2. HADOOP-7755

Detect MapReduce PreCommit Trunk builds silently failing when running test-patch.sh

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.23.0, 0.24.0
    • Fix Version/s: 0.23.0
    • Component/s: build
    • Labels:
      None

      Description

      MapReduce PreCommit build is silently failing only running a very small portion of tests. The build then errors out, yet +1 it given to the patch.

      Last known Success build - 307 tests run and passed
      https://builds.apache.org/view/G-L/view/Hadoop/job/PreCommit-MAPREDUCE-Build/990/testReport/

      First known Error build - 69 tests run and passed
      https://builds.apache.org/view/G-L/view/Hadoop/job/PreCommit-MAPREDUCE-Build/994/testReport/

      Snippet from failed build log - Errors out and then +1 the patch
      https://builds.apache.org/view/G-L/view/Hadoop/job/PreCommit-MAPREDUCE-Build/994/console

      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO]
      [INFO] hadoop-yarn-api ................................... SUCCESS [19.512s]
      [INFO] hadoop-yarn-common ................................ FAILURE [13.835s]
      [INFO] hadoop-yarn-server-common ......................... SKIPPED
      [INFO] hadoop-yarn-server-nodemanager .................... SKIPPED
      [INFO] hadoop-yarn-server-resourcemanager ................ SKIPPED
      [INFO] hadoop-yarn-server-tests .......................... SKIPPED
      [INFO] hadoop-yarn-server ................................ SKIPPED
      [INFO] hadoop-yarn-applications-distributedshell ......... SKIPPED
      [INFO] hadoop-yarn-applications .......................... SKIPPED
      [INFO] hadoop-yarn-site .................................. SKIPPED
      [INFO] hadoop-yarn ....................................... SKIPPED
      [INFO] hadoop-mapreduce-client-core ...................... SKIPPED
      [INFO] hadoop-mapreduce-client-common .................... SKIPPED
      [INFO] hadoop-mapreduce-client-shuffle ................... SKIPPED
      [INFO] hadoop-mapreduce-client-app ....................... SKIPPED
      [INFO] hadoop-mapreduce-client-hs ........................ SKIPPED
      [INFO] hadoop-mapreduce-client-jobclient ................. SKIPPED
      [INFO] hadoop-mapreduce-client ........................... SKIPPED
      [INFO] hadoop-mapreduce .................................. SKIPPED
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 33.784s
      [INFO] Finished at: Wed Oct 12 12:03:22 UTC 2011
      [INFO] Final Memory: 40M/630M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.2-beta-5:single (tar) on project hadoop-yarn-common: Failed to create assembly: Error adding file 'org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT' to archive: /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-api/target/classes isn't a file. -> [Help 1]
      [ERROR]
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
      [ERROR]
      [ERROR] After correcting the problems, you can resume the build with the command
      [ERROR] mvn <goals> -rf :hadoop-yarn-common

      ======================================================================
      ======================================================================
      Running contrib tests.
      ======================================================================
      ======================================================================

      /bin/kill -9 27543
      kill: No such process
      NOP

      ======================================================================
      ======================================================================
      Checking the integrity of system test framework code.
      ======================================================================
      ======================================================================

      /bin/kill -9 27548
      kill: No such process
      NOP

      +1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12498577/MR3166.patch
      against trunk revision .

      +1 @author. The patch does not contain any @author tags.

      +1 tests included. The patch appears to include 3 new or modified tests.

      +1 javadoc. The javadoc tool did not generate any warning messages.

      +1 javac. The applied patch does not increase the total number of javac compiler warnings.

      +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      +1 core tests. The patch passed unit tests in .

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/994//testReport/
      Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/994//console

      This message is automatically generated.

      1. HADOOP-7755.patch
        1 kB
        Jonathan Eagles

        Activity

        Chris Riccomini added a comment -

        Yea, I just noticed this as well. It seems to have been going on for quite some time. I should also note that the -1 I got in https://issues.apache.org/jira/browse/MAPREDUCE-3068 for javadocs seems to be transient, and appears in a lot of tests.

        Chris Riccomini added a comment -

        Based on the hudson chart, it appears to have started between 993 and 994:

        https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/993/console
        https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/994/console

        994 contains:

        MAPREDUCE-3157. [Rumen] Fix TraceBuilder to handle 0.20 history file names also. (detail/ViewSVN)
        MAPREDUCE-3125. Modified TaskImpl to consider only non-failed, non-killed task-attempts for obtaining task's progress. Contributed by Hitesh Shah. (detail/ViewSVN)
        Move line for HDFS-2422 under 0.23 instead of 0.24. (detail/ViewSVN)
        Move the HADOOP-6490 Changes note to the right section. Accidentally placed it under Bugs in r1182189. (detail/ViewSVN)
        MAPREDUCE-3140. Fixed the invalid JobHistory URL for failed applications. Contributed by Subroto Sanyal. (detail/ViewSVN)
        HADOOP-7736. Remove duplicate Path#normalizePath call. (detail/ViewSVN)
        HDFS-2349. Corruption detected during block transfers should log WARNs. (detail/ViewSVN)
        HADOOP-6490. Use StringUtils over String#replace in Path#normalizePath. Contributed by Uma Maheswara Rao G. (detail/ViewSVN)
        HADOOP-7642. create hadoop-dist module where TAR stitching would happen. Contributed by Thomas White. (detail/ViewSVN)

        Not sure if any of this is relevant/helps. The Hudson test chart has been running flat at 69 tests ever since.

        Jonathan Eagles added a comment -

        Guessing ... but I see HADOOP-7642 made some changes to the version of the assemblies plugin as well some other assemblies plugin changes. I will investigate this a little, perhaps by submitting the reverse patch for experimentation.

        Chris Riccomini added a comment -

        Yea, that's the one that made me nervous as well. Look forward to your findings.

        Jonathan Eagles added a comment -

        I did find a maven issue that may be of some help to understand a fix.

        http://jira.codehaus.org/browse/MDEP-259

        Arun C Murthy added a comment -

        Jonathan, thanks for looking into this. A speedy resolution will help a lot!

        Mahadev konar added a comment -

        Also, we should add this as list of jiras along with the maven backport to 0.23.

        Jonathan Eagles added a comment -

        Can anyone with build conf access post what the exact test-patch command is being executed by jenkins? It seems that another occurrence of this issue in auth is masking the error in mapreduce. Thanks.

        Mahadev konar added a comment -

        Here's the script:

        #!/bin/bash
        set +x
        
        source ${WORKSPACE}/nightly/hudsonEnv.sh
        
        mkdir -p ${WORKSPACE}/patchprocess
        
        cd ${TRUNK}
        
        /bin/bash ${TRUNK}/dev-support/test-patch.sh \
                --jenkins \
                --patch-dir=${WORKSPACE}/patchprocess \
                --basedir=${TRUNK}/hadoop-mapreduce-project \
                --support-dir=/home/jenkins/buildSupport \
                --ps-cmd=/bin/ps \
                --wget-cmd=/usr/bin/wget \
                --svn-cmd=/usr/bin/svn \
                --grep-cmd=/bin/grep \
                --patch-cmd=/usr/bin/patch \
                --jira-cmd=/home/jenkins/tools/jiracli/latest/jira 
                --findbugs-home=/home/jenkins/tools/findbugs/latest \
                --forrest-home=/home/jenkins/tools/forrest/latest \
                --eclipse--home=/home/jenkins/tools/eclipse/latest \
                MAPREDUCE-${ISSUE_NUM}
        
        Jonathan Eagles added a comment -

        Terrific! Thanks, Mahadev!

        Jonathan Eagles added a comment -

        I was never able to fully reproduce this error exactly as the reactor build still always had Auth problems. Not sure how to remove those from the build.

        [INFO] Apache Hadoop Main ................................ SUCCESS [1.028s]
        [INFO] Apache Hadoop Project POM ......................... SUCCESS [0.784s]
        [INFO] Apache Hadoop Annotations ......................... SUCCESS [3.069s]
        [INFO] Apache Hadoop Project Dist POM .................... SUCCESS [0.666s]
        [INFO] Apache Hadoop Assemblies .......................... SUCCESS [0.286s]
        [INFO] Apache Hadoop Auth ................................ SUCCESS [7.141s]
        [INFO] Apache Hadoop Auth Examples ....................... FAILURE [1.472s]
        [INFO] Apache Hadoop Common .............................. SKIPPED
        [INFO] Apache Hadoop Common Project ...................... SKIPPED
        [INFO] Apache Hadoop HDFS ................................ SKIPPED
        [INFO] Apache Hadoop HDFS Project ........................ SKIPPED
        [INFO] hadoop-yarn ....................................... SKIPPED
        [INFO] hadoop-yarn-api ................................... SKIPPED
        [INFO] hadoop-yarn-common ................................ SKIPPED
        [INFO] hadoop-yarn-server ................................ SKIPPED
        [INFO] hadoop-yarn-server-common ......................... SKIPPED
        [INFO] hadoop-yarn-server-nodemanager .................... SKIPPED
        [INFO] hadoop-yarn-server-resourcemanager ................ SKIPPED
        [INFO] hadoop-yarn-server-tests .......................... SKIPPED
        [INFO] hadoop-yarn-applications .......................... SKIPPED
        [INFO] hadoop-yarn-applications-distributedshell ......... SKIPPED
        [INFO] hadoop-yarn-site .................................. SKIPPED
        [INFO] hadoop-mapreduce-client ........................... SKIPPED
        [INFO] hadoop-mapreduce-client-core ...................... SKIPPED
        [INFO] hadoop-mapreduce-client-common .................... SKIPPED
        [INFO] hadoop-mapreduce-client-shuffle ................... SKIPPED
        [INFO] hadoop-mapreduce-client-app ....................... SKIPPED
        [INFO] hadoop-mapreduce-client-hs ........................ SKIPPED
        [INFO] hadoop-mapreduce-client-jobclient ................. SKIPPED
        [INFO] hadoop-mapreduce .................................. SKIPPED
        [INFO] Apache Hadoop Tools ............................... SKIPPED
        [INFO] Apache Hadoop Distribution ........................ SKIPPED

        Jonathan Eagles added a comment -

        Since the issue is fixed for now. Plan is to use this ticket to fix test-patch.sh to permanently prevent this type of error in the future.

        Jonathan Eagles added a comment -

        Why this happens is that the maven test command can fail in such a way that no tests fails and yet not all the tests are run because of the failure.

        Ideas:

        1) Detect non-zero exit status for maven test command and -1 the patch.
        2) File a long term fix that will -1 a patch if the number of tests has been [significantly] reduced

        Jonathan Eagles added a comment -

        Reverting to the earlier logic in test-patch.sh that continues fail patches when the core-test fails to build.

        Jonathan Eagles added a comment -

        Manually tested change by
        1) Successful build and tests still +1 core test
        2) Successful build and failed tests -1 build with failures listed.
        3) Failed build with no failed tests -1 build with build broken message.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12499588/HADOOP-7755.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 4 new or modified tests.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/303//console

        This message is automatically generated.

        Jonathan Eagles added a comment -

        Hadoop QA still doesn't recognized patches in dev-support. Here are the test-patch results from my desk. Findbugs warnings are unrelated to the patch.

        -1 overall.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to introduce 163 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch failed the unit tests build in.

        +1 contrib tests. The patch passed contrib unit tests.

        Tom White added a comment -

        +1

        Tom White added a comment -

        I just committed this. Thanks, Jonathan!

        Hudson added a comment -

        Integrated in Hadoop-Common-0.23-Commit #20 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/20/)
        Merge -r 1185921:1185922 from trunk to branch-0.23. Fixes:HADOOP-7755.

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185923
        Files :

        • /hadoop/common/branches/branch-0.23/dev-support/test-patch.sh
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1184 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1184/)
        HADOOP-7755. Detect MapReduce PreCommit Trunk builds silently failing when running test-patch.sh. Contributed by Jonathan Eagles

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185922
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.sh
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Commit #21 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/21/)
        Merge -r 1185921:1185922 from trunk to branch-0.23. Fixes:HADOOP-7755.

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185923
        Files :

        • /hadoop/common/branches/branch-0.23/dev-support/test-patch.sh
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #1105 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1105/)
        HADOOP-7755. Detect MapReduce PreCommit Trunk builds silently failing when running test-patch.sh. Contributed by Jonathan Eagles

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185922
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.sh
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #1124 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1124/)
        HADOOP-7755. Detect MapReduce PreCommit Trunk builds silently failing when running test-patch.sh. Contributed by Jonathan Eagles

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185922
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.sh
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Commit #21 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/21/)
        Merge -r 1185921:1185922 from trunk to branch-0.23. Fixes:HADOOP-7755.

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185923
        Files :

        • /hadoop/common/branches/branch-0.23/dev-support/test-patch.sh
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #44 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/44/)
        Merge -r 1185921:1185922 from trunk to branch-0.23. Fixes:HADOOP-7755.

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185923
        Files :

        • /hadoop/common/branches/branch-0.23/dev-support/test-patch.sh
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #865 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/865/)
        HADOOP-7755. Detect MapReduce PreCommit Trunk builds silently failing when running test-patch.sh. Contributed by Jonathan Eagles

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185922
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.sh
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Build #56 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/56/)
        Merge -r 1185921:1185922 from trunk to branch-0.23. Fixes:HADOOP-7755.

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185923
        Files :

        • /hadoop/common/branches/branch-0.23/dev-support/test-patch.sh
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #835 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/835/)
        HADOOP-7755. Detect MapReduce PreCommit Trunk builds silently failing when running test-patch.sh. Contributed by Jonathan Eagles

        tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185922
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.sh
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Jonathan Eagles added a comment -

        Thanks, Tom.


          People

          • Assignee:
            Jonathan Eagles
            Reporter:
            Jonathan Eagles
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development