Hadoop Common
  1. Hadoop Common
  2. HADOOP-775

If the tasktracker kills a task it cleans up the job directory as well

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      If the tasktracker kills a task it will clean up the job directory as well. So if other tasks of the same job will later fail saying there is no job.xml or job.jar

      1. jobdirfix.patch
        3 kB
        Mahadev konar

        Issue Links

          Activity

          Mahadev konar added a comment -

          this patch fixes the problem. The job directory is only cleaned up when all the tasks for the job on the tasktracker have finished (completed or failed).

          Arun C Murthy added a comment -

          Mahadev, Sanjay reported this first here: HADOOP-737; and HADOOP-639 tries to get this accomplised via directions from the JobTracker to the TaskTracker... can you review HADOOP-639 and check if it meets your needs? If so, we could resolve this issue as a 'duplicate'... thanks!

          Mahadev konar added a comment -

          thanks for pointing it out arun. I should have goen thorugh the bugs before filing and fixing it . I just read went through the patch for HADOOP-639. It does seem to solve the problem. We can mark this one as duplicate.

          Arun C Murthy added a comment -

          Duplicate of HADOOP-737, fixed as a part of HADOOP-639


            People

            • Assignee:
              Arun C Murthy
              Reporter:
              Mahadev konar
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development