Hadoop Common
  1. Hadoop Common
  2. HADOOP-7416

Allow test-patch to work with cross sub-project changes

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Now that the sub-projects are sub-directories in the same repo, we can make test-patch.sh not barf on cross-project patches. We would need to make smart-apply-patch.sh not fail hard when it detects this, and probably make test-patch.sh run all the validation checks against all affected sub-projects.

      This was inspired by HDFS-1900, which changes a config in Common that's referenced in a bunch of places in HDFS.

      1. HADOOP-7416.patch
        4 kB
        Aaron T. Myers

        Issue Links

          Activity

          Aaron T. Myers added a comment -

          Resolving as duplicate of HADOOP-8308.

          Aaron T. Myers added a comment -

          Not marking patch available since I'm confident test-patch won't know what to do with this change.

          Aaron T. Myers added a comment -

          Here's a patch which partially addresses the issue. This will allow for cross-sub-project patches to apply cleanly, and will comment with a "-0 patch..." in the JIRA comment if this is detected. It won't actually run all of the tests from all affected modules. Since that's a substantially more involved change, and since this change should help considerably, I'd like to punt that to a separate JIRA.

          I tested this patch by creating a few uni-project and multi-project patches, and running test-patch manually. With this change, test-patch successfully applies and detects cross-sub-project patches.

          John George added a comment -

          wanted to add HADOOP-6889 for reference: test-patch failed because the patch was hdfs specific, but uploaded in a common sub-project.


            People

            • Assignee:
              Aaron T. Myers
              Reporter:
              Aaron T. Myers
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development