Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.0
    • Component/s: fs
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Need to refactor cat & text to conform to new FsCommand class.

      1. HADOOP-7238-2.patch
        19 kB
        Daryn Sharp
      2. HADOOP-7238.patch
        19 kB
        Daryn Sharp

        Issue Links

          Activity

          Daryn Sharp added a comment -

          Split out the commands.
          Update the usage.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12477730/HADOOP-7238.patch
          against trunk revision 1097322.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/386//testReport/
          Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/386//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/386//console

          This message is automatically generated.

          Matt Foley added a comment -

          I especially like the re-implementation of printToStdout() as IOUtils.copyBytes().

          Didn't read all the nitty-gritty details of the implementation that DIDN'T change, I assume you transcribed them correctly.

          +1 code review.

          Daryn Sharp added a comment -

          Yes, the file magic checks and the TextRecordInputStream are not changed. Cut-n-paste.

          Tsz Wo Nicholas Sze added a comment -

          Daryn, the patch does not apply anymore.

          Daryn Sharp added a comment -

          update patch to resolve conflicts in if/then/else chains caused by removal of other commands

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12478631/HADOOP-7238-2.patch
          against trunk revision 1101132.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/419//testReport/
          Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/419//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/419//console

          This message is automatically generated.

          Tsz Wo Nicholas Sze added a comment -

          I have committed this. Thanks, Daryn!

          Also thanks Matt for reviewing it.

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #582 (See https://builds.apache.org/hudson/job/Hadoop-Common-trunk-Commit/582/)
          HADOOP-7238. Refactor the cat and text commands to conform to new FsCommand class. Contributed by Daryn Sharp

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk #684 (See https://builds.apache.org/hudson/job/Hadoop-Common-trunk/684/)
          HADOOP-7238. Refactor the cat and text commands to conform to new FsCommand class. Contributed by Daryn Sharp


            People

            • Assignee:
              Daryn Sharp
              Reporter:
              Daryn Sharp
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development