Hadoop Common
  1. Hadoop Common
  2. HADOOP-6847

Problem staging 0.21.0 artifacts to Apache Nexus Maven Repository

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      I get this error:

      -mvn-system-deploy:
      [artifact:install-provider] Installing provider: org.apache.maven.wagon:wagon-http:jar:1.0-beta-2:runtime
      [artifact:deploy] Deploying to https://repository.apache.org/content/repositories/snapshots
      [artifact:deploy] Uploading: org/apache/hadoop/hadoop-common-instrumented/0.21.0/hadoop-common-instrumented-0.21.0.jar to apache.snapshots.https
      [artifact:deploy] Uploaded 1331K
      [artifact:deploy] An error has occurred while processing the Maven artifact tasks.
      [artifact:deploy]  Diagnosis:
      [artifact:deploy] 
      [artifact:deploy] Error deploying artifact 'org.apache.hadoop:hadoop-common-instrumented:jar': Error deploying artifact: Failed to transfer file: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-common-instrumented/0.21.0/hadoop-common-instrumented-0.21.0.jar. Return code is: 400
      

      Note that 400 is "Bad Request", not an authentication error (401).

      1. hadoop-6847.patch
        11 kB
        Giridharan Kesavan

        Issue Links

          Activity

          Giridharan Kesavan added a comment -

          this patch should fix the issue with uploading artifacts to the nexus maven repo.

          command to upload artifact to the staging rep is ;

          ant mvn-deploy -Dversion="standard version string" -Drepo=staging

          command to upload artifact to the snapshot repo is:

          ant mvn-deploy

          I 've tried publishing artifacts to the staging repo and it worked.
          https://repository.apache.org/index.html#staging;6a441994c87797, this stating url is not closed yet for to get a public view.

          Konstantin Boudnik added a comment -

          +1 patch looks good. Let's verify it.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12448784/hadoop-6847.patch
          against trunk revision 960137.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/601/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/601/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/601/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/601/console

          This message is automatically generated.

          Tom White added a comment -

          +1

          I managed to publish artifacts to the staging repo too (I had to add a server section to ~/.m2/settings.xml with an ID of apache.staging.https for it to work). Thanks for fixing this, Giri. I think we need equivalent fixes for HDFS and MapReduce.

          Konstantin Boudnik added a comment -

          JavaDoc warning is caused by some FindBugs issue and isn't related to the patch. I'll be committing this shortly.

          Konstantin Boudnik added a comment -

          I have committed this both to branch0.21 and the trunk. Thanks Giri!

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #321 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk-Commit/321/)
          HADOOP-6847. Problem staging 0.21.0 artifacts to Apache Nexus Maven Repository. Contributed by Giridharan Kesavan

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk #390 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk/390/)


            People

            • Assignee:
              Giridharan Kesavan
              Reporter:
              Tom White
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development