Hadoop Common
  1. Hadoop Common
  2. HADOOP-6654

Example in WritableComparable javadoc doesn't compile

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: io
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    1. HADOOP-6654.patch
      1 kB
      Tom White
    2. hadoop-4881.patch
      1 kB
      Tom White

      Activity

      Tom White added a comment -

      Patch with an example that compiles.

      Tsz Wo Nicholas Sze added a comment -

      +1 patch looks good.

      Tom White added a comment -

      Updated patch to apply to trunk; also moved back to common project since the problem is in org.apache.hadoop.io.WritableComparable, not MapReduce.

      Hadoop QA added a comment -

      -1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12439472/HADOOP-6654.patch
      against trunk revision 925528.

      +1 @author. The patch does not contain any @author tags.

      -1 tests included. The patch doesn't appear to include any new or modified tests.
      Please justify why no new tests are needed for this patch.
      Also please list what manual steps were performed to verify this patch.

      +1 javadoc. The javadoc tool did not generate any warning messages.

      +1 javac. The applied patch does not increase the total number of javac compiler warnings.

      +1 findbugs. The patch does not introduce any new Findbugs warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      +1 core tests. The patch passed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/426/testReport/
      Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/426/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/426/artifact/trunk/build/test/checkstyle-errors.html
      Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/426/console

      This message is automatically generated.

      Tom White added a comment -

      No tests are needed since this only changes documentation.

      Tsz Wo Nicholas Sze added a comment -

      I have committed this. Thanks, Tom!

      Hudson added a comment -

      Integrated in Hadoop-Common-trunk-Commit #212 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk-Commit/212/)
      . Fix code example in WritableComparable javadoc. Contributed by Tom White

      Hudson added a comment -

      Integrated in Hadoop-Common-trunk #288 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk/288/)
      . Fix code example in WritableComparable javadoc. Contributed by Tom White


        People

        • Assignee:
          Tom White
          Reporter:
          Tom White
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development