Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.20.1
    • Fix Version/s: 0.21.0
    • Component/s: io
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TestUTF8 is actually flaky. It generates 10 random strings to run the test on. If you change this number to 100000 it fails every time.

      1. HADOOP-6522.patch
        2 kB
        Doug Cutting
      2. HADOOP-6522.patch
        2 kB
        Doug Cutting
      3. HADOOP-6522.patch
        2 kB
        Doug Cutting

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk #246 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk/246/)
          . Fix decoding of codepoint zero in UTF8.

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #162 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk-Commit/162/)
          . Fix decoding of codepoint zero in UTF8.

          Doug Cutting added a comment -

          I just committed this to trunk and to the 0.21 branch.

          Doug Cutting added a comment -

          > Should this go into 0.20?

          I doubt it's causing any real problems, but it wouldn't hurt.

          Chris Douglas added a comment -

          +1

          Should this go into 0.20?

          Doug Cutting added a comment -

          Anyone care to wager how long this will stay in the "Patch Available" state before another committer reviews it?

          Doug Cutting added a comment -

          Can another committer please review this so that I may commit it?

          Todd Lipcon added a comment -

          lgtm

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12434696/HADOOP-6522.patch
          against trunk revision 906177.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/325/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/325/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/325/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/325/console

          This message is automatically generated.

          Doug Cutting added a comment -

          New version of patch that suppresses deprecation warnings in TestUTF8.

          Doug Cutting added a comment -

          New deprecation warning was created by the addition of a new UTF8 test, since UTF8 is deprecated.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12434693/HADOOP-6522.patch
          against trunk revision 905860.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          -1 javac. The applied patch generated 1029 javac compiler warnings (more than the trunk's current 1028 warnings).

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/324/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/324/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/324/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/324/console

          This message is automatically generated.

          Doug Cutting added a comment -

          Here's a new version of the patch that includes a test that specifically tests for the prior bug. The new test, testNullEncoding(), fails every time without the patch and passes every time with it.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12434612/HADOOP-6522.patch
          against trunk revision 904975.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/318/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/318/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/318/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/318/console

          This message is automatically generated.

          Eli Collins added a comment -

          Patch looks good to me. Perhaps worth adding a test case that covers the null character explicitly.

          Doug Cutting added a comment -

          The problem is that the null character (codepoint zero) was correctly encoded but incorrectly decoded. I've attached a patch that fixes this and increases the size of the tests so that problems like this will likely be discovered sooner.


            People

            • Assignee:
              Doug Cutting
              Reporter:
              Todd Lipcon
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development