Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.21.0, 0.22.0
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      There's a number of occasions when TestHDFSCLI reports a successful execution however doesn't run any tests at all.
      For a typical case please take a look here

      1. hadoop-6409.txt
        0.8 kB
        Todd Lipcon
      2. hadoop-6409.txt
        0.7 kB
        Todd Lipcon

        Issue Links

          Activity

          Konstantin Boudnik created issue -
          Konstantin Boudnik made changes -
          Field Original Value New Value
          Link This issue is related to HDFS-794 [ HDFS-794 ]
          Konstantin Boudnik added a comment -

          TestHDFSCLI has to have an internal verification mechanism which can check the validity of the reported results. E.g. the very minimal check should fail the test if number of passed tests equals 0.

          Todd Lipcon added a comment -

          Think this should be a HADOOP jira - TestHDFSCLI uses TestCLI from common - I think we just need to assert that testsFromConfigFile.size() > 0 at the top of testAll(). If you agree, I'll move the jira and upload a patch

          Konstantin Boudnik made changes -
          Project Hadoop HDFS [ 12310942 ] Hadoop Common [ 12310240 ]
          Key HDFS-805 HADOOP-6409
          Affects Version/s 0.21.0 [ 12313563 ]
          Affects Version/s 0.22.0 [ 12314296 ]
          Affects Version/s 0.21.0 [ 12314046 ]
          Affects Version/s 0.22.0 [ 12314241 ]
          Konstantin Boudnik added a comment -

          oops, I have read your comment a half way through and moved the JIRA right away. Then I came back to read the second part of your comment Sorry. Please go ahead and send the patch in. Thanks!

          Todd Lipcon added a comment -

          Trivial patch to add assertion that some tests are configured.

          Todd Lipcon made changes -
          Attachment hadoop-6409.txt [ 12426814 ]
          Todd Lipcon made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Assignee Todd Lipcon [ tlipcon ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12426814/hadoop-6409.txt
          against trunk revision 886645.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/163/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/163/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/163/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/163/console

          This message is automatically generated.

          Todd Lipcon made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Todd Lipcon added a comment -

          Well, that's silly. TestCLI, the base class, doesn't run any tests since it's just meant to be inherited from. New patch does something slightly ugly to make this check not be triggered for TestCLI itself. Ran the test locally and it passes for common.

          Todd Lipcon made changes -
          Attachment hadoop-6409.txt [ 12426820 ]
          Todd Lipcon made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12426820/hadoop-6409.txt
          against trunk revision 886645.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/164/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/164/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/164/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/164/console

          This message is automatically generated.

          Konstantin Boudnik added a comment -

          Well, apparently it didn't work because according to the test log non of the test cases were ran. However, no assertion has been made either.

          Todd Lipcon added a comment -

          Right, the TestCLI in Common has no tests, so one would expect that nothing would run. It's the TestHDFSCLI in HDFS that actually runs tests - it just inherits cross-project to this one.

          Now that I look closer, the original hudson link was to the common TestCLI, which again has nothing in it.

          The reason we started looking at this was the regression from HADOOP-6375 which broke TestHDFSCLI but Hudson didn't pick it up. This is because that was a common patch and not an HDFS patch, and thus the tests against du weren't supposed to run.

          Really the central issue here is that a common feature (FsShell) is being tested from HDFS. We should resolve this one as wontfix and open another JIRA to put the tests that cover FsShell in common and make TestHDFSCLI only test HDFS-specific stuff.

          Konstantin Boudnik added a comment -

          Now that I look closer, the original hudson link was to the common TestCLI, which again has nothing in it.

          Well, I think you right. you might be right. This class isn't a test per se. It is a helper class which isn't intended to have any tests. However, because it has Test prefix is being picked up by JUnit and executed as a normal test. What we need to do is to rename this class to something like CLITestHelper

          I still believe that your patch makes sense, actually.

          Konstantin Boudnik made changes -
          Link This issue is related to HADOOP-6222 [ HADOOP-6222 ]
          Konstantin Boudnik added a comment -

          Todd, feel free to convert this JIRA to be a subtask of HADOOP-6222 so it all can be fixed at the same time.

          Todd Lipcon made changes -
          Parent HADOOP-6222 [ 12434330 ]
          Issue Type Bug [ 1 ] Sub-task [ 7 ]
          Tom White added a comment -

          Removing from queue while Konstantin's suggestion is addressed.

          Tom White made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Konstantin Boudnik added a comment -

          Committed as a part of HADOOP-6222. Thank you Todd.

          Konstantin Boudnik made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Hadoop Flags [Reviewed]
          Fix Version/s 0.22.0 [ 12314296 ]
          Resolution Fixed [ 1 ]
          Tom White made changes -
          Fix Version/s 0.21.0 [ 12313563 ]
          Fix Version/s 0.22.0 [ 12314296 ]
          Tom White made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          1h 12m 2 Todd Lipcon 03/Dec/09 22:02
          Patch Available Patch Available Open Open
          11d 1h 44m 2 Tom White 14/Dec/09 23:17
          Open Open Resolved Resolved
          20h 45m 1 Konstantin Boudnik 15/Dec/09 20:02
          Resolved Resolved Closed Closed
          252d 38m 1 Tom White 24/Aug/10 21:41

            People

            • Assignee:
              Todd Lipcon
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development