Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: contrib/cloud
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      For example, if an ec2-authorize command fails the script should stop so that the problem is easier to debug.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        29d 23h 19m 1 Tom White 26/Jun/09 14:41
        Resolved Resolved Closed Closed
        424d 6h 57m 1 Tom White 24/Aug/10 21:38
        Tom White made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk #9 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk/9/)
        . EC2 scripts should exit on error.

        Tom White made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Fix Version/s 0.21.0 [ 12313563 ]
        Resolution Fixed [ 1 ]
        Tom White added a comment -

        I've just committed this.

        Tom White added a comment -
             [exec] -1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     -1 tests included.  The patch doesn't appear to include any new or modified tests.
             [exec]                         Please justify why no new tests are needed for this patch.
             [exec]                         Also please list what manual steps were performed to verify this patch.
             [exec] 
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec] 
             [exec]     -1 javac.  The applied patch generated 64 javac compiler warnings (more than the trunk's current 124 warnings).
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec] 
             [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
        

        There are no tests for the current EC2 scripts, so I tested this manually by running through starting a cluster, running a job, and shutting the cluster down. I tested a failure by setting an invalid key name.

        The -1 for javac is odd, since the number went down according to the message, and furthermore this patch doesn't change any Java code.

        Todd Lipcon added a comment -

        +1. Looks good to me.

        Tom White made changes -
        Field Original Value New Value
        Attachment hadoop-5925.patch [ 12409170 ]
        Tom White added a comment -

        Path that uses "set -o errexit".

        Tom White created issue -

          People

          • Assignee:
            Tom White
            Reporter:
            Tom White
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development