Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    1. Hadoop-5792.patch
      3 kB
      Giridharan Kesavan
    2. Hadoop-5792.patch
      3 kB
      Giridharan Kesavan
    3. Hadoop-5792.patch
      3 kB
      Giridharan Kesavan

      Issue Links

        Activity

        Giridharan Kesavan created issue -
        Giridharan Kesavan added a comment -

        this resolves jsp-2.1 using ivy

        Nigel,
        Could you please review this?

        Giridharan Kesavan made changes -
        Field Original Value New Value
        Attachment Hadoop-5792.patch [ 12407623 ]
        steve_l added a comment -

        think there is a typo in the hdfs-proxy build.xml, version is spelled vesion:
        core-$

        {core.vesion}

        .jar"/>

        Nigel Daley added a comment -

        Giri or Steve, is this correct in the ivy.xml?

        + rev="$

        Unknown macro: {jetty.version}

        "

        (I'm probably not the right person to review this.)

        Giridharan Kesavan added a comment -

        fixed the typo mentioned by Steve, also updated the jsp- jar location in the .classpath file.

        tnx for the comments Steve.

        Giridharan Kesavan made changes -
        Attachment Hadoop-5792.patch [ 12407765 ]
        Giridharan Kesavan made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12407765/Hadoop-5792.patch
        against trunk revision 773542.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        -1 Eclipse classpath. The patch causes the Eclipse classpath to differ from the contents of the lib directories.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/323/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/323/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/323/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/323/console

        This message is automatically generated.

        Giridharan Kesavan made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Giridharan Kesavan added a comment -

        resubmiting patch to hudson which fixed the eclipse .classpath

        Giridharan Kesavan made changes -
        Attachment Hadoop-5792.patch [ 12407798 ]
        Giridharan Kesavan made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12407798/Hadoop-5792.patch
        against trunk revision 773791.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        -1 Eclipse classpath. The patch causes the Eclipse classpath to differ from the contents of the lib directories.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/326/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/326/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/326/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/326/console

        This message is automatically generated.

        Giridharan Kesavan added a comment - - edited

        -1 to eclipse classpath is expected as this patch runs through the hudson test-patch.
        Reason: jsp-2.1 folder is not deleted from the lib folder yet and hence this jars adds to the classpath though, it's resolved through ivy.

        we may have to remove lib/jsp-2.1 folder before committing this patch to svn.

        1) Apply this patch:
        2) svn rm lib/jsp-2.1 ( this would remove jsp-2.1 dir with jsp-api and jsp-2.1.jar )
        3) svn ci

        Thanks,

        Nigel Daley added a comment -

        +1

        Giridharan Kesavan added a comment -

        I just committed this, thanks Steve and Nigel
        Committed revision 774224

        tnx!

        Giridharan Kesavan made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Resolution Fixed [ 1 ]
        Chris Douglas added a comment -

        This issue is causing TestQueueCapacities to fail in trunk

        Chris Douglas made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Chris Douglas added a comment -

        Perhaps I spoke too soon. The ClassNotFoundExceptions from the unit test:

            [junit] Caused by: java.lang.ClassNotFoundException: org.apache.jasper.runtime.JspSourceDependent
            [junit]     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
            [junit]     at java.security.AccessController.doPrivileged(Native Method)
            [junit]     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
            [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:316)
            [junit]     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:288)
            [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
            [junit]     at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:374)
            [junit]     ... 57 more
        

        and corresponding fetch failures appear to be caused by this patch, but the test still times out after reverting both commits (in the future, please follow the commit message conventions and include the issue ID and- where possible- commit once per issue).

        Chris Douglas made changes -
        Fix Version/s 0.21.0 [ 12313563 ]
        Component/s build [ 12311543 ]
        Chris Douglas added a comment -

        I reverted this so HADOOP-4981, HADOOP-5869 can be resolved.

        steve_l added a comment -

        findjar implies that this missing file should be in the jsp-2.1.jar

        http://www.findjar.com/class/org/apache/jasper/runtime/JspSourceDependent.html

        Giridharan Kesavan made changes -
        Link This issue is blocked by HADOOP-5869 [ HADOOP-5869 ]
        steve_l added a comment -

        org.apache.jasper.runtime.JspSourceDependent is in jsp-2.1 JAR. I'd thought maybe there is an import there that is showing up, but no, this is an interface with no imports

        http://svn.apache.org/viewvc/tomcat/jasper/tc6.0.x/src/share/org/apache/jasper/runtime/JspSourceDependent.java?revision=369286

        Giridharan Kesavan added a comment -

        this jira is not valid anymore

        Giridharan Kesavan made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Invalid [ 6 ]
        Tom White made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Giridharan Kesavan
            Reporter:
            Giridharan Kesavan
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development