Hadoop Common
  1. Hadoop Common
  2. HADOOP-5611

C++ libraries do not build on Debian Lenny

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.18.3, 0.19.0, 0.19.1, 0.20.205.0
    • Fix Version/s: 0.20.2
    • Component/s: None
    • Labels:
      None
    • Environment:

      Debian Lenny, 64 bit

    • Hadoop Flags:
      Reviewed

      Description

      The compilation of the C++ util and Hadoop Pipes code generates some errors about undefined functions. It appears there are just some missing includes that must not affect some other systems. Attaching a patch that fixes this issue.

        Activity

        Joep Rottinghuis added a comment -

        Uhm, the note should read:

        MAPREDUCE-1251 must also be applied after this patch.

        Joep Rottinghuis added a comment -

        This is not Debian specific. The same happens on RHEL6.
        The root cause is a cleanup of header files in Gcc 4.3 which exposes missing includes.
        As Sreekanth pointed out in HADOOP-5678, this is documented in http://www.cyrius.com/journal/2007/05/10#gcc-4.3-include

        RHEL5 uses gcc 4.1.2
        RHEL6 uses gcc 4.4.5
        Ubuntu Natty Narwhal uses gcc 4.5.2

        This should be applied to branch-0.20-security and the 0.20.205 branch.

        Note that HADOOP-5611 must also be applied after this patch.

        Hudson added a comment -

        Integrated in Hadoop-Common-trunk #247 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk/247/)
        . Commit to branch 0.20

        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #163 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk-Commit/163/)
        . Commit to branch 0.20

        Chris Douglas added a comment -

        I committed this to the 0.20 branch.

        The C++ code should probably make use of the std namespace instead of using global imports, but that is a broader, more pervasive issue that can be dealt with separately.

        Todd Lipcon added a comment -

        This should be committed to branch-0.20 as well, since it causes a fail to build from release source on many systems.

        Hudson added a comment -
        Tom White added a comment -

        I've just committed this. Thanks Todd!

        Todd Lipcon added a comment -

        Upping this to critical priority since does-not-build-from-source is pretty serious in my opinion.

        Todd Lipcon added a comment -

        The failing tests seem to be scheduler-related:

        org.apache.hadoop.mapred.TestQueueCapacities.testSingleQueue
        org.apache.hadoop.mapred.TestQueueCapacities.testSingleQueueMultipleJobs
        org.apache.hadoop.mapred.TestQueueCapacities.testMultipleQueues

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12404588/HADOOP-5611-fixed.patch
        against trunk revision 763247.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/165/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/165/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/165/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/165/console

        This message is automatically generated.

        Todd Lipcon added a comment -

        Reuploading patch with -p0 this time so it should apply automatically.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12404374/0001-HADOOP-5611-Add-some-missing-includes-to-c-code-t.patch
        against trunk revision 761082.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-minerva.apache.org/94/console

        This message is automatically generated.

        Todd Lipcon added a comment -

        Author: Todd Lipcon <todd@cloudera.com>
        Date: Wed Apr 1 16:39:07 2009 -0400

        HADOOP-5611: Add some missing includes to c++ code to fix compilation on Debian Lenny


          People

          • Assignee:
            Todd Lipcon
            Reporter:
            Todd Lipcon
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development