Hadoop Common
  1. Hadoop Common
  2. HADOOP-5491

Better control memory usage in contrib/index

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The combiner was originally designed to work only on the map side. When used on the reduce side, it may use too much memory.

      1. hadoop-5491.patch
        5 kB
        Ning Li
      2. hadoop-5491.patch
        4 kB
        Ning Li
      3. hadoop-5491.patch
        4 kB
        Ning Li
      4. hadoop-5491.patch
        5 kB
        Ning Li

        Activity

        Ning Li created issue -
        Ning Li made changes -
        Field Original Value New Value
        Attachment hadoop-5491.patch [ 12402173 ]
        Ning Li added a comment -

        A configuration parameter "sea.max.ramsize.bytes" is added to limit the size of a ram index created by a combiner.

        Ning Li made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12402173/hadoop-5491.patch
        against trunk revision 753449.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-minerva.apache.org/64/console

        This message is automatically generated.

        Ning Li added a comment -

        The patch fixes memory usage problem, so there is no new or modified test.

        Ning Li made changes -
        Attachment hadoop-5491.patch [ 12402180 ]
        Ning Li made changes -
        Status Patch Available [ 10002 ] In Progress [ 3 ]
        Ning Li made changes -
        Attachment hadoop-5491.patch [ 12402288 ]
        Ning Li added a comment -

        Hmm, "submit patch" is not shown as an available workflow action.

        Doug Cutting added a comment -

        > Hmm, "submit patch" is not shown as an available workflow action.

        How about now that the issue is assigned to you?

        Doug Cutting made changes -
        Assignee Ning Li [ ningli ]
        Ning Li added a comment -

        "Submit patch" is available again now that I'm assignee. Thanks, Doug.

        Ning Li made changes -
        Status In Progress [ 3 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12402288/hadoop-5491.patch
        against trunk revision 754927.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/91/console

        This message is automatically generated.

        Ning Li added a comment -

        I used dos2unix, but Hudson still cannot apply patch. Anyone has an idea why?

        Doug Cutting added a comment -

        > I used dos2unix, but Hudson still cannot apply patch.

        The problem is that the committed code uses CRLF and your patch uses only LF.

        Ning Li made changes -
        Status Patch Available [ 10002 ] In Progress [ 3 ]
        Ning Li made changes -
        Attachment hadoop-5491.patch [ 12403541 ]
        Ning Li made changes -
        Status In Progress [ 3 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12403541/hadoop-5491.patch
        against trunk revision 757958.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/132/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/132/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/132/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/132/console

        This message is automatically generated.

        Ning Li added a comment -

        The failed test is not related to this patch.

        Doug Cutting added a comment -

        I just committed this. Thanks, Ning!

        Doug Cutting made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Fix Version/s 0.21.0 [ 12313563 ]
        Resolution Fixed [ 1 ]
        Tom White made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Ning Li
            Reporter:
            Ning Li
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development